avr-gcc-list
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [avr-gcc-list] Inserting code before context save in an ISR(forneste


From: Eric Weddington
Subject: RE: [avr-gcc-list] Inserting code before context save in an ISR(fornested interrupts)
Date: Mon, 13 Aug 2007 12:19:37 -0600


> -----Original Message-----
> From:
> address@hidden
> [mailto:address@hidden
> org] On Behalf Of Christian Ludlam
> Sent: Monday, August 13, 2007 5:20 AM
> To: address@hidden
> Subject: Re: [avr-gcc-list] Inserting code before context
> save in an ISR(fornested interrupts)
>
> On 7 Aug Joerg Wunsch wrote:
>
> > Eric Weddington <address@hidden> wrote:
> >
> > > And to do this using avr-libc, is to use the INTERRUPT() macro
> > > (instead of ISR()):
> >
> > ....which has been deprecated, due to its confusing name.
> >
> > So the "official" solution is:
> >
> > void YOUR_VECTOR_vect(void) __attribute__((interrupt));
> > void
> > YOUR_VECTOR_vect(void)
> > {
> >    /* your ISR goes here */
> > }
>
> Oh that's awful! I don't see why using a clumsy attribute
> syntax with the
> same deprecated name is any less confusing... can't we add a
> new macro,
> something like REENTRANT_ISR() or ISR_SEI()?

Yes, it's the deprecated macro, INTERRUPT(). These macros expand to the
attribute syntax anyway.

Eric






reply via email to

[Prev in Thread] Current Thread [Next in Thread]