bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

style: rename function for clarity


From: Akim Demaille
Subject: style: rename function for clarity
Date: Mon, 25 Feb 2019 06:21:59 +0100

commit ec8142391aa9dd07e628eb142963618097ba522b
Author: Akim Demaille <address@hidden>
Date:   Sun Feb 24 20:49:39 2019 +0100

    style: rename function for clarity
    
    Commit db34f7988941444bdc5f2b6adcf7fb83648f9a18 renames the variable F
    as goto_follows, but forgot to rename this function.
    
    * src/lalr.c (initialize_F): Rename as...
    (initialize_goto_follows): this.

diff --git a/src/lalr.c b/src/lalr.c
index 46cf01e5..4e2b255c 100644
--- a/src/lalr.c
+++ b/src/lalr.c
@@ -158,7 +158,7 @@ map_goto (state_number src, symbol_number sym)
 
 /* Build goto_follows. */
 static void
-initialize_F (void)
+initialize_goto_follows (void)
 {
   goto_number **reads = xnmalloc (ngotos, sizeof *reads);
   goto_number *edge = xnmalloc (ngotos + 1, sizeof *edge);
@@ -457,7 +457,7 @@ lalr (void)
 {
   initialize_LA ();
   set_goto_map ();
-  initialize_F ();
+  initialize_goto_follows ();
   lookback = xcalloc (nLA, sizeof *lookback);
   build_relations ();
   compute_follows ();




reply via email to

[Prev in Thread] Current Thread [Next in Thread]