[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: getline.c and ssize_t

From: Bruno Haible
Subject: Re: getline.c and ssize_t
Date: Mon, 26 Nov 2007 14:42:58 +0100
User-agent: KMail/1.5.4

Micah Cowan wrote:
> While attempting to compile sed from current CVS, I ran across the
> following output from bootstrap.sh:
>   + cc -DHAVE_CONFIG_H -I.. -I. -c getline.c
>   getline.c:26: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’
> before ‘getline’
> Line 26 is the ssize_t return-type of getline. Adding #include
> <unistd.h> fixed it (I'm sure <sys/types.h> would too).
> Unfortunately, after fixing that, I ran into
>   cc: mbchar.c: No such file or directory
> which I suspect to be just sed's bootstrap not being up-to-date with
> current gnulib

Everything looks correct in the current gnulib; in particular ssize_t
gets defined by <sys/types.h>, included by gnulib's <stdio.h> override.

Therefore I suspect, like you, that the use of gnulib in sed is not up-to-date;
please write to the email address in `sed --help` about this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]