classpath
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: java.io.File#toURI()


From: Mark Wielaard
Subject: Re: java.io.File#toURI()
Date: Wed, 02 Jun 2004 20:21:10 +0200

Hi Ito,

On Tue, 2004-06-01 at 16:48, Ito Kazumitsu wrote:
> I am afraid java.io.File#toURI() is not correctly implemented now.

Ugh. What an embarrasing bug. I checked in the original buggy code.
Sorry.

> 2004-06-01 Ito Kazumitsu  <address@hidden>
> 
>       * libraries/javalib/java/io/File.java
>       (toURI): Use new URI(scheme, userInfo, host, port, path,
>       query, fragment).

For GNU Classpath please use the short java/io/File.java file name in
the ChangeLog entry.

Kaffe hackers, could it be an idea to split you changelog into a
general, libraries/clib and libraries/javalib one? That way the GNU
Classpath ChangeLog merging/importing becomes much easier.

> --- java/io/File.java.orig    Tue Jun  1 22:52:28 2004
> +++ java/io/File.java Tue Jun  1 23:40:33 2004
> @@ -781,7 +781,8 @@
>          
>      try
>        {
> -     return new URI("file", "", abspath.replace(separatorChar, '/'));
> +     return new URI("file", null, null, -1,
> +     abspath.replace(separatorChar, '/'), null, null);
>        }
>      catch (URISyntaxException use)
>        {

Thanks for spotting this.
But could you indent it like:

+       return new URI("file", null, null, -1,
+                      abspath.replace(separatorChar, '/'),
+                      null, null);

That makes it slightly more readable.

Thanks,

Mark

P.S. Please send patch suggestions to address@hidden They
might be lost on the general list.

Attachment: signature.asc
Description: This is a digitally signed message part


reply via email to

[Prev in Thread] Current Thread [Next in Thread]