denemo-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Denemo-devel] added excerpt and export export to png support


From: Jeremiah Benham
Subject: Re: [Denemo-devel] added excerpt and export export to png support
Date: Fri, 06 Jun 2008 09:15:28 -0500

On Fri, 2008-06-06 at 10:30 +0100, Richard Shann wrote:
> This is an excellent addition - thanks. Your use of a LilyControl field
> called excerpt is astute - 

Thanks!

> we should put the other parameters to the
> print command in there - the start, end, all, as they are all control
> for the print command.

Agreed.

> About a dialog to select the excerpt - I suggest using the selection:
> you drag the mouse over the music you want to excerpt and hit Print
> Excerpt and you have a png! I suspect it is trivial to do - shall I look
> at it?

Sure. You already did something similar with the playback thing. I
suggest after the user selects a range with the mouse, a pop up dialog
then appears that has a range selection in it similar to what we have in
playback properties. This way if the user doesn't select with the mouse
first then they don't get confused. I can do the pop-up dialog if you do
the mouse selection stuff.  

> I've pulled it from git, and tried build but it can't find the
> definition of
> PrintExcerptPreview_cb
> which you may have in another file?

Oops. That was in print.c/.h. I just pushed that to git. 

> Also - this function adopts a different naming convention to all its
> siblings - printpreview_cb, printall_cb etc. Keeping a uniform naming
> convention helps code legibility - there are already at least two naming
> conventions being used at this point in the code. I like the
> UpDownNamingConvention myself, 

I prefer the updown convention also. It helps me to spell them and helps
to read it I think. I can start to change them if you like. Since we are
on a similar topic. What convention do you want to follow for tabs and
spaces. I notice some code that looks like:

function(){
}

and some that looks like

function()
{
}

Also I see:

void
function()

and :

void function()

Frequently I see tab/spaces like this:
if ()
  Dothis;

and:

if ()
        DoThis; 

How many spaces for tabs. When to use tabs spaces. We should probably
agree on these things. I think someone mentioned a document on coding
style guide a while back. Are you following some code style guide. If
there is not one out there we can recommend contributers follow than
perhaps we should write one of our own. 

Jeremiah


> but I think it is up to us to change all
> the names to suit if we feel strongly about one convention or the other,
> but above all, not to make the code more mixed-up than it is.
> 
> Richard
> 
> 
> On Thu, 2008-06-05 at 18:18 -0500, Jeremiah Benham wrote:
> > I just committed a change to git to allow users to export to png or
> > create music excerpts. At the moment it is not completely finished. In
> > the future it should have a dialog or something to ask you which
> > measures to create an excerpt from. This way the user wants to create a
> > one or two measure exercise that can be included in an OpenOffice.org
> > document or something. Note that it does not print the entire page. This
> > is the intended result. Later I also plan on adding .eps for inclusion
> > in LaTeX documents. 
> > 
> > This way a user can use denemo in combination with OpenOffice.org or
> > LaTeX to create books that have musical examples in it. 
> > 
> > Jeremiah
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Denemo-devel mailing list
> > address@hidden
> > http://lists.gnu.org/mailman/listinfo/denemo-devel
> > 
> > 
> 





reply via email to

[Prev in Thread] Current Thread [Next in Thread]