emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Interactive specs of C functions.


From: Stefan Monnier
Subject: Re: Interactive specs of C functions.
Date: Sun, 09 Sep 2007 17:19:29 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/23.0.50 (gnu/linux)

> ***************
> *** 770,777 ****
  
>     if (SUBRP (fun))
>       {
> !       if (XSUBR (fun)->prompt)
> !     return list2 (Qinteractive, build_string (XSUBR (fun)->prompt));
>       }
>     else if (COMPILEDP (fun))
>       {
> --- 770,777 ----
  
>     if (SUBRP (fun))
>       {
> !       if (XSUBR (fun)->intspec)
> !     return list2 (Qinteractive, build_string (XSUBR (fun)->intspec));
>       }
>     else if (COMPILEDP (fun))
>       {

This doesn't look right.  It should do the Fread_from_string thingy as well.

> + (defun char-to-who (char)
> +   "Convert CHAR to a who-mask from a symbolic mode notation.
> + CHAR is in [ugoa] and represents the users on which rights are applied."
[...]
> + (defun char-to-right (char &optional from)
> +   "Convert CHAR to a right-mask from a symbolic mode notation.
> + CHAR is in [rwxXstugo] and represents a right.
> + If CHAR is in [Xugo], the value is extracted from FROM (or 0 if nil)."
[...]
> + (defun right-string-to-number (rights who-mask &optional from)
> +   "Convert a right string to a right-mask from a symbolic modes notation.
> + RIGHTS is the right string, it should match \"([+=-][rwxXstugo]+)+\".
> + WHO-MASK is the mask number of the users on which the rights are to be 
> applied.
> + FROM (or 0 if nil) is the orginal modes of the file to be chmod'ed."

These names are too generic compared to the job they do.  I'd add
a "file-modes" prefix or somesuch.


        Stefan




reply via email to

[Prev in Thread] Current Thread [Next in Thread]