emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFC] allocating intervals as vectors


From: Stefan Monnier
Subject: Re: [RFC] allocating intervals as vectors
Date: Wed, 29 Aug 2012 09:51:03 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2.50 (gnu/linux)

If IIUC this adds 2 words for each interval object (from 7 to 9).
That seems high for the minor benefits we get in return.


        Stefan


> -  unsigned gcmarkbit : 1;
> -
> -  /* The remaining components are `properties' of the interval.
> -     The first four are duplicates for things which can be on the list,
> -     for purposes of speed.  */
> -
> -  unsigned int write_protect : 1;   /* Non-zero means can't modify.  */
> -  unsigned int visible : 1;      /* Zero means don't display.  */
> -  unsigned int front_sticky : 1;    /* Non-zero means text inserted just
> -                                    before this interval goes into it.  */
> -  unsigned int rear_sticky : 1;          /* Likewise for just after it.  */
> -  Lisp_Object plist;             /* Other properties.  */
> +  /* These properties can be on the list, but cached for the sake of speed.  
> */
> +
> +  /* Non-zero means can't modify.  */
> +  unsigned int write_protect : 1;
> +
> +  /* Zero means don't display.  */
> +  unsigned int visible : 1;
> +
> +  /* Non-zero means text inserted just before this interval goes into it.  */
> +  unsigned int front_sticky : 1;
> +
> +  /* Likewise for just after it.  */
> +  unsigned int rear_sticky : 1;
>  };

Could you please try to avoid such cosmetic changes in your patches?
Especially since they make the code more difficult to read in my
opinion (the whole struct doesn't fit as comfortably on a single screen,
and there's more comments interspersed with the field declarations).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]