emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MS-Windows build using Posix configury


From: Eli Zaretskii
Subject: Re: MS-Windows build using Posix configury
Date: Wed, 17 Apr 2013 20:00:11 +0300

> Date: Tue, 16 Apr 2013 20:33:18 -0700
> From: Paul Eggert <address@hidden>
> CC: address@hidden
> 
> Thanks for getting this to work.

Thanks for reviewing the changes.

> > -       cd $(DESTDIR)${bindir} && $(LN_S) $(EMACSFULL) $(EMACS); \
> > +       cd $(DESTDIR)${bindir} && $(LN_EMACS) $(EMACSFULL) $(EMACS); \
> 
> Why prefer hard links on Windows but not everywhere else?

I don't know why we moved to symlinks here.  Perhaps Glenn could
comment on that.

> How about something like the following instead?
> 
>     cd $(DESTDIR)${bindir} && { \
>       ln $(EMACSFULL) $(EMACS) 2>/dev/null || $(LN_S) $(EMACSFULL) $(EMACS); \
>     }; \
> 
> That way, we don't need LN_EMACS.

Right, fine with me.  But see also my other mail on this issue.

> > +if test "${opsys}" = "mingw32"; then
> > +  if test "${with_xpm}" != "no"; then
> > +    AC_CHECK_HEADER(X11/xpm.h, HAVE_XPM=yes, HAVE_XPM=no, [
> > +#define FOR_MSW 1])
> > +  fi
> > +
> > +  if test "${HAVE_XPM}" = "yes"; then
> > +    AC_DEFINE(HAVE_XPM, 1, [Define to 1 if you have the Xpm library 
> > (-lXpm).])
> > +  fi
> > +fi
> 
> There are a number of instances of code like this, where a reasonably
> large amount of code is duplicated and surrounded by "if test
> "${opsys}" = "mingw32".  It'd be better to duplicate less code and do
> the mingw32-specific stuff more compactly.  Perhaps this is too much
> to do right now, but at least this deserves a FIXME, as in the long
> run this is increasing maintenance effort.

Right.  For the record, the reason why I didn't bring these instances
together is that they test for optional libraries one by one, and I
thought keeping the tests related to each library together was more
important than avoiding some code duplication.

> > +if test "${opsys}" = "mingw32"; then
> > +  AC_DEFINE(NULL_DEVICE, ["NUL:"], [Name of the file to open to get
> > +    a null file, or a data sink.])
> > +else
> > +  AC_DEFINE(NULL_DEVICE, ["/dev/null"], [Name of the file to open to get
> > +    a null file, or a data sink.])
> > +fi
> 
> For stuff like this, how about putting it into conf_post.h instead?

Fine with me.  However, Glenn suggested another solution, one that
involves other similar macros (like SEPCHAR).  Which way to use?

Thanks for the other suggestions, I will implement them all.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]