emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 64-bit build on Windows


From: Fabrice Popineau
Subject: Re: 64-bit build on Windows
Date: Sun, 22 Jan 2017 21:38:39 +0100



2017-01-22 17:50 GMT+01:00 Eli Zaretskii <address@hidden>:
> From: Fabrice Popineau <address@hidden>
> Date: Sat, 21 Jan 2017 21:40:44 +0100
> Cc: Juanma Barranquero <address@hidden>, Óscar Fuentes <address@hidden>,
>       Emacs developers <address@hidden>
>
>  Please describe how this would work, without using
>  dynamic-library-alist.
>
> But I never said that it would work without using dynamic-library-alist ?

Then it seems we are in violent agreement about this.

This sub-thread started when I said ImageMagick was not supported on
Windows because it could only be linked in statically.  You disagreed
with that, but now it looks like you actually agree, and posted a
patch to add the missing stuff.

> +       '(magickwand "libMagickWand-7.Q16HDRI-0.dll" "libMagickWand-7.Q16-0.dll")
> +       '(magickcore "libMagickCore-7.Q16HDRI-0.dll" "libMagickCore-7.Q16-0.dll")


Does this mean we will only support ImageMagick 7.x and later on
Windows?  If so, the configure-time test should be changed, since it
currently allows 6.x, I think.
 
Given that MSYS2 itself has switched to IM7, I don't see the point to keep support forIM6.
 
> +static bool
> +init_imagemagick_functions (void)
> +{
> +  HMODULE magickwand, magickcore;
> +
> +  if (!(magickcore = w32_delayed_load (Qmagickcore))
> +      || !(magickwand = w32_delayed_load (Qmagickwand)))
> +    return 0;

Are these 2 DLLs completely independent?  Or will loading one of them
automatically load the other, due to dependencies?


Actually, it seems that magickwand depends on magickcore.
However, you may need later on a handle on both dlls to catch the functions each one holds.
 
 
> @@ -8406,7 +8776,7 @@ imagemagick_compute_animated_image (MagickWand *super_wand, int ino)
>        PixelWand **source, **dest;
>        size_t source_width, source_height;
>        ssize_t source_left, source_top;
> -      MagickPixelPacket pixel;
> +      PixelInfo pixel;

What is this about?


AFAIR they changed the names of a few structures.
 
> +#if defined HAVE_NTGUI && !defined CYGWIN

A.k.a. "#ifdef WINDOWSNT".


Ok.

Fabrice


reply via email to

[Prev in Thread] Current Thread [Next in Thread]