gnash-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-commit] /srv/bzr/gnash/trunk r9764: Clarify ownership of network


From: Benjamin Wolsey
Subject: [Gnash-commit] /srv/bzr/gnash/trunk r9764: Clarify ownership of network streams.
Date: Wed, 17 Sep 2008 15:12:23 +0200
User-agent: Bazaar (1.5)

------------------------------------------------------------
revno: 9764
committer: Benjamin Wolsey <address@hidden>
branch nick: trunk
timestamp: Wed 2008-09-17 15:12:23 +0200
message:
  Clarify ownership of network streams.
  
  Implement addRequestHeaders for XML and LoadVars correctly (passes in swfdec
  and for new tests in actionscript.all). There's quite a bit of code 
duplication
  for these two classes.
  
  Rename various as classes for consistency.
renamed:
  libcore/asobj/LoadVars.cpp => libcore/asobj/LoadVars_as.cpp
  libcore/asobj/LoadVars.h => libcore/asobj/LoadVars_as.h
  libcore/asobj/xml.cpp => libcore/asobj/XML_as.cpp
  libcore/asobj/xml.h => libcore/asobj/XML_as.h
modified:
  libbase/NetworkAdapter.h
  libbase/curl_adapter.cpp
  libcore/StreamProvider.cpp
  libcore/StreamProvider.h
  libcore/array.cpp
  libcore/array.h
  libcore/as_function.cpp
  libcore/as_object.cpp
  libcore/as_value.cpp
  libcore/asobj/AsBroadcaster.cpp
  libcore/asobj/ClassHierarchy.cpp
  libcore/asobj/Global.cpp
  libcore/asobj/Makefile.am
  libcore/asobj/MovieClipLoader.cpp
  libcore/asobj/NetConnection.cpp
  libcore/asobj/NetStreamFfmpeg.cpp
  libcore/asobj/String_as.cpp
  libcore/asobj/XMLSocket_as.cpp
  libcore/asobj/xmlnode.cpp
  libcore/edit_text_character.cpp
  libcore/impl.cpp
  libcore/namedStrings.cpp
  libcore/namedStrings.h
  libcore/swf_function.cpp
  libcore/swf_function.h
  libcore/timers.cpp
  libcore/vm/Machine.cpp
  testsuite/actionscript.all/XML.as
  testsuite/libbase/CurlStreamTest.cpp
  testsuite/swfdec/PASSING
  libcore/asobj/LoadVars_as.cpp
  libcore/asobj/XML_as.cpp
  libcore/asobj/XML_as.h
    ------------------------------------------------------------
    revno: 9756.1.1
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Tue 2008-09-16 19:45:34 +0200
    message:
      Rename XML and LoadVars classes to XML_as and LoadVars_as.
      
      Implement addRequestHeaders for LoadVars (as much as it's implemented for
      XML).
    renamed:
      libcore/asobj/LoadVars.cpp => libcore/asobj/LoadVars_as.cpp
      libcore/asobj/LoadVars.h => libcore/asobj/LoadVars_as.h
      libcore/asobj/xml.cpp => libcore/asobj/XML_as.cpp
      libcore/asobj/xml.h => libcore/asobj/XML_as.h
    modified:
      libcore/asobj/ClassHierarchy.cpp
      libcore/asobj/Global.cpp
      libcore/asobj/Makefile.am
      libcore/asobj/XMLSocket_as.cpp
      libcore/timers.cpp
      testsuite/libbase/CurlStreamTest.cpp
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
      libcore/asobj/XML_as.h
    ------------------------------------------------------------
    revno: 9756.1.2
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Tue 2008-09-16 20:28:52 +0200
    message:
      Change as_array_object's iterator names back to iterator and 
const_iterator.
      Make container typedef private to discourage external use.
    modified:
      libcore/array.cpp
      libcore/array.h
    ------------------------------------------------------------
    revno: 9756.1.3
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 08:42:46 +0200
    message:
      Send the request headers to NetworkAdapter.
    modified:
      libcore/asobj/LoadVars_as.cpp
    ------------------------------------------------------------
    revno: 9756.1.4
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 09:16:12 +0200
    message:
      Pass network streams by auto_ptr, as ownership should always be 
transferred.
    modified:
      libbase/NetworkAdapter.h
      libbase/curl_adapter.cpp
      libcore/StreamProvider.cpp
      libcore/StreamProvider.h
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/NetConnection.cpp
      libcore/asobj/NetStreamFfmpeg.cpp
      libcore/asobj/XML_as.cpp
      libcore/impl.cpp
    ------------------------------------------------------------
    revno: 9756.1.5
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 09:27:11 +0200
    message:
      Rename as_array_object to Array_as.
    modified:
      libcore/array.cpp
      libcore/array.h
      libcore/as_function.cpp
      libcore/as_object.cpp
      libcore/as_value.cpp
      libcore/asobj/AsBroadcaster.cpp
      libcore/asobj/MovieClipLoader.cpp
      libcore/asobj/String_as.cpp
      libcore/asobj/XML_as.cpp
      libcore/asobj/xmlnode.cpp
      libcore/edit_text_character.cpp
      libcore/swf_function.cpp
      libcore/swf_function.h
      libcore/vm/Machine.cpp
    ------------------------------------------------------------
    revno: 9756.1.6
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 10:07:39 +0200
    message:
      Implement array argument to addRequestHeader (much faster for sparse
      arrays than the pp) for both XML and LoadVars.
      
      Because I've used a map with a no-case alphabetic comparator (so that
      duplicates overwrite any previous value as expected), the headers are
      sent in a different order from the pp, which seems to use array index 
order.
    modified:
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
    ------------------------------------------------------------
    revno: 9756.1.7
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 11:04:11 +0200
    message:
      Check Request headers against a set of reserved names before settting.
      
      These are all the documented ones plus GET, POST and HEAD. Any others?
    modified:
      libbase/NetworkAdapter.h
      libbase/curl_adapter.cpp
    ------------------------------------------------------------
    revno: 9756.1.8
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 11:16:55 +0200
    message:
      Implement contentType property for LoadVars and XML.
    modified:
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
    ------------------------------------------------------------
    revno: 9756.1.9
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 11:37:55 +0200
    message:
      Don't access non-existent object.
    modified:
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
    ------------------------------------------------------------
    revno: 9756.1.10
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 13:23:01 +0200
    message:
      Rearrange addRequestHeaders to use an AS array (_customHeaders property) 
for
      storing headers in both XML and LoadVars.
      
      Test in XML.as for _customHeaders.
    modified:
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
      libcore/asobj/XML_as.h
      testsuite/actionscript.all/XML.as
    ------------------------------------------------------------
    revno: 9756.1.11
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 14:47:53 +0200
    message:
      Add _customHeaders and concat to named strings.
      
      Push elements of an array argument to addRequestHeadesr to the 
_customHeaders
      array in pairs, as expected.
    modified:
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
      libcore/namedStrings.cpp
      libcore/namedStrings.h
    ------------------------------------------------------------
    revno: 9756.1.12
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 14:52:55 +0200
    message:
      The existing _customHeaders object doesn't have to be an array.
    modified:
      libcore/asobj/LoadVars_as.cpp
      libcore/asobj/XML_as.cpp
    ------------------------------------------------------------
    revno: 9756.1.13
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 14:54:54 +0200
    message:
      Correct expected totals.
    modified:
      testsuite/actionscript.all/XML.as
    ------------------------------------------------------------
    revno: 9756.1.14
    committer: Benjamin Wolsey <address@hidden>
    branch nick: work
    timestamp: Wed 2008-09-17 15:03:58 +0200
    message:
      swfdec passes (addRequestHeaders).
    modified:
      testsuite/swfdec/PASSING
Diff too large for email (3281 lines, the limit is 1000).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]