help-rcs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: dispatch program


From: Paul Eggert
Subject: Re: dispatch program
Date: Thu, 03 Nov 2011 13:24:00 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20110927 Thunderbird/7.0

On 11/03/11 05:34, Thien-Thi Nguyen wrote:
>   A new name is much simpler.

A new name might be simpler to implement, but it's more
complicated for users, and we should think of users first.

Why not just stick with "rcs"?  If done right, it won't
affect practical existing uses of the "rcs" command,
as the old and new syntaxes won't collide.  Internally,
the new "rcs" could dispatch to the "old" one,
if that's convenient, but users needn't worry about this
detail.

Once this is done, we could have something like this:

  rcs ci     == ci
  rcs co     == co
  rcs clean  == rcsclean
  rcs diff   == rcsdiff
  rcs merge  == rcsmerge
  rcs log    == rlog
  rcs init   == rcs -i (the "old" rcs)
  rcs admin  == rcs without -i (the "old" rcs)

One more thing: the "new" rcs should use GNU getopt,
and not have options that have optional arguments, as
the argument-parsing gorp of the "old" rcs is one of
its greatest annoyances, and we might as well fix this
problem now if we're changing the API anyway.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]