lilypond-user
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 4-Drum Conga Notation in LilyPond


From: Eric Pancer
Subject: Re: 4-Drum Conga Notation in LilyPond
Date: Sun, 16 Dec 2012 09:22:52 -0600

On Thu, Dec 13, 2012 at 10:55 AM, Eric Pancer <address@hidden> wrote:
> On Wed, Dec 12, 2012 at 6:05 PM, Thomas Morley
> <address@hidden> wrote:
>> 2012/12/12 Eric Pancer <address@hidden>:
>>> On Wed, Dec 12, 2012 at 2:33 PM, Eric Pancer <address@hidden> wrote:
> [..]
>>> I've got this working using the following definition:
>>>
>>> #(define mydrums '(
>>> (bassdrum  default   #f  -3)
>>> (snare        default   #f    0)
>>> (hihat         default     #f  1)
>>> (lowtom     default   #f     3)))
>>>
>>> Of course I don't exactly understand what the #f is, but do get the
>>> numerical values are positions in the staff. A bit of explanation
>>> could help me.
>>
>> Every entry in your new list consists of the name, note-head,
>> use-which-script-sign? and staff-position.
>
> Thank you. Where is that documented? I don't understand what #f is, or
> how it compares to #t. Also, the line position is confusing. Is C6
> considered "0"?
>
>>>> Also, is there an easy way to make each pitch with an "x" (slap)?
>>
>> I'm not sure what you want with the "x-slap". Below I've set the
>> NoteHead to cross and additional I've used some crazy script-signs to
>> demonstrate. I'm sure you'll want to alter them. :)
>>
>> You could have a look in /ly/drumpitch-init.ly and in /scm/script.scm
>> for more info about the code.
>>
>> \version "2.16.1"
>>
>> #(define mydrums '(
>>                    (bassdrum  cross   "coda" -3)
>>                    (snare     cross   "upbow"   0)
>>                    (hihat     cross   "espressivo"   1)
>>                    (lowtom    cross   "reverseturn"   3)))
>>
>> dr = \drummode { bd4 sn hh toml }
>>
>> \new DrumStaff <<
>>   \set DrumStaff.drumStyleTable = #(alist->hash-table mydrums)
>>   \new DrumVoice \dr
>
> Thank you for the example. What I'm thinking is that I should just
> define a whole new drum configuration since it would be easier to read
> and write. I'd like to do the following: quinto (E6), conga (C6),
> hitumba (A5), lotumba (F5) (with a generic "tumba" equal to
> "hitumba"). I've patched
> /Applications/LilyPond.app/Contents/Resources/share/lilypond/current/ly/drumpitch-init.ly
> (see diff below), but the following snippet only puts 4 quarter notes
> in the middle line of a percussion staff:

Perhaps I should send this to the devel list, instead?

>
> \new DrumStaff <<
>   \drummode {
>     quinto4 conga4 hitumba4 mutelotumba4
>   }
>>>
>
> Thanks for any help. Here's the diff:
>
> --- drumpitch-init.ly.old       2012-12-13 09:28:05.000000000 -0600
> +++ drumpitch-init.ly   2012-12-13 10:46:39.000000000 -0600
> @@ -40,12 +40,21 @@ drumPitchNames =
>     (mutelobongo . mutelobongo)
>     (lobongo . lobongo)
>     (openlobongo . openlobongo)
> -   (mutehiconga . mutehiconga)
> -   (muteloconga . muteloconga)
> -   (openhiconga . openhiconga)
> -   (hiconga . hiconga)
> -   (openloconga . openloconga)
> -   (loconga . loconga)
> +   (quinto . quinto)
> +   (openquinto . openquinto)
> +   (mutequinto . mutequinto)
> +   (conga . conga)
> +   (openconga . openconga)
> +   (muteconga . muteconga)
> +   (tumba . tumba)
> +   (opentumba . opentumba)
> +   (mutetumba . mutetumba)
> +   (lotumba . lotumba)
> +   (openlotumba . openlotumba)
> +   (mutelotumba . mutelotumba)
> +   (hitumba . hitumba)
> +   (openhitumba . openhitumba)
> +   (mutehitumba . mutehitumba)
>     (hitimbale . hitimbale)
>     (lotimbale . lotimbale)
>     (hiagogo . hiagogo)
> @@ -113,12 +122,16 @@ drumPitchNames =
>     (bolm . mutelobongo)
>     (bol . lobongo)
>     (bolo . openlobongo)
> -   (cghm . mutehiconga)
> -   (cglm . muteloconga)
> -   (cgho . openhiconga)
> -   (cgh . hiconga)
> -   (cglo . openloconga)
> -   (cgl . loconga)
> +   (qnto . openquinto)
> +   (qntm . mutequinto)
> +   (cgo . openconga)
> +   (cgm . muteconga)
> +   (tmbo . opentumba)
> +   (tmbm . mutetumba)
> +   (tmbho . openhitumba)
> +   (tmbhm . mutehitumba)
> +   (tmblo . openhitumba)
> +   (tmblm . mutelotumba)
>     (timh . hitimbale)
>     (timl . lotimbale)
>     (agh . hiagogo)
> @@ -190,12 +203,21 @@ midiDrumPitches = #`(
>         (mutelobongo . ,(ly:make-pitch -1 6 DOUBLE-SHARP))
>         (lobongo . ,(ly:make-pitch 0 0 SHARP))
>         (openlobongo . ,(ly:make-pitch 0 1 FLAT))
> -       (mutehiconga . ,(ly:make-pitch 0 1 NATURAL))
> -       (muteloconga . ,(ly:make-pitch 0 2 DOUBLE-FLAT))
> -       (openhiconga . ,(ly:make-pitch 0 1 SHARP))
> -       (hiconga . ,(ly:make-pitch 0 2 FLAT))
> -       (openloconga . ,(ly:make-pitch 0 1 DOUBLE-SHARP))
> -       (loconga . ,(ly:make-pitch 0 2 NATURAL))
> +       (quinto . ,(ly:make-pitch 0 3 NATURAL))
> +       (openquinto . ,(ly:make-pitch 0 3 NATURAL))
> +       (mutequinto . ,(ly:make-pitch 0 3 SHARP))
> +       (conga . ,(ly:make-pitch 0 1 NATURAL))
> +       (openconga . ,(ly:make-pitch 0 1 NATURAL))
> +       (muteconga . ,(ly:make-pitch 0 1 SHARP))
> +       (tumba . ,(ly:make-pitch 0 -1 NATURAL))
> +       (opentumba . ,(ly:make-pitch 0 -1 NATURAL))
> +       (mutetumba . ,(ly:make-pitch 0 -1 SHARP))
> +       (hitumba . ,(ly:make-pitch 0 -1 NATURAL))
> +       (openhitumba . ,(ly:make-pitch 0 -1 NATURAL))
> +       (mutehitumba . ,(ly:make-pitch 0 -1 SHARP))
> +       (lotumba . ,(ly:make-pitch 0 -3 NATURAL))
> +       (openlotumba . ,(ly:make-pitch 0 -3 NATURAL))
> +       (mutelotumba . ,(ly:make-pitch 0 -3 SHARP))
>         (hitimbale . ,(ly:make-pitch 0 3 NATURAL))
>         (lotimbale . ,(ly:make-pitch 0 3 SHARP))
>         (hiagogo . ,(ly:make-pitch 0 4 NATURAL))
> @@ -280,13 +302,22 @@ midiDrumPitches = #`(
>
>     (congas-style .
>       ((losidestick cross #f -1)
> -      (loconga () #f -1)
> -      (openloconga () "open" -1)
> -      (muteloconga () "stopped" -1)
>        (hisidestick cross #f 1)
> -      (hiconga () #f 1)
> -      (openhiconga () "open" 1)
> -      (mutehiconga () "stopped" 1)
> +      (quinto () #f 3)
> +      (openquinto () "open" 3)
> +      (mutequinto () "stopped" 3)
> +      (conga () #f 1)
> +      (openconga () "open" 1)
> +      (muteconga () "stopped" 1)
> +      (tumba () #f -1)
> +      (opentumba () "open" -1)
> +      (mutetumba () "stopped" -1)
> +      (hitumba () #f -1)
> +      (openhitumba () "open" -1)
> +      (mutehitumba () "stopped" -1)
> +      (lotumba () #f -3)
> +      (openlotumba () "open" -3)
> +      (mutelotumba () "stopped" -3)
>        ))



reply via email to

[Prev in Thread] Current Thread [Next in Thread]