lilypond-user
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Arranging lyrics between 2 staves


From: David Sumbler
Subject: Re: Arranging lyrics between 2 staves
Date: Tue, 14 Feb 2017 11:39:53 +0000

On Mon, 2017-02-13 at 12:20 -0500, Kieren MacMillan wrote:
> Hi David,
> 
> > 
> > That seems to work perfectly.
> Glad to hear it.
> 
> > 
> > I'll experiment a bit with the 2 VerticalAxisGroup settings, to see
> > if
> > I can understand the effect each of them has, for my greater
> > understanding!
> Excellent.
> 
> Speaking of greater understanding… Here is a version in which I use
> variables — if there really are no differences in pitches (only
> octaves), this approach (which I actually recommend in every piece!)
> might save you some effort and make your code far more easily
> maintained:
> 
> \version "2.19.48"
> \language "english"
> 
> \layout {
>     \context {
>         \Lyrics
>         \override VerticalAxisGroup.staff-affinity = #CENTER
>         \override VerticalAxisGroup.nonstaff-relatedstaff-
> spacing.padding = #1.5
>     }
> }
> 
> the_notes = {
>     g2 g a1 g2 g a1
>     \bar  "|."
> }
> 
> the_lyrics = \lyricmode {
>     Words just right! Words just right!
> }
> 
> \new StaffGroup <<
>     \new Staff
>     \new Voice = "upper" { \clef "bass" \the_notes  }
>     \new Lyrics \lyricsto "upper" \the_lyrics
>     \new Staff = "lower" { \clef "bass" \transpose c c, \the_notes }
> > 
> > > 
> > > 
> Best,
> Kieren.

Actually, for once I'm ahead of you!  What you suggested is almost
exactly what I already had.  The addition of an alternative mezzo line
was an after-thought.  Originally for each song I had something akin to

voiceMoray = <music>

When I decided to add the mezzo line, I changed this for clarity to

baritoneMoray = <music>

and then added 

mezzoMoray = \transpose c c' \baritoneMoray

A few months ago I spent a lot of time trying to create a structure
which would enable me easily to control which postscript and midi files
were created at each run of Lilypond, and which section(s) of a whole
piece would be included.  This is so that I can continually recompile
as I work, and thus check the validity of my input.  The template I
ended up with involves lots of \include statements, with included files
which themselves contain includes down several levels, but it works
well once I have got the initial files set up for a particular piece.
 It certainly has made my life a lot easier than it was when I was
trying to manage great blocks of commented out code in a very long
file.

David




reply via email to

[Prev in Thread] Current Thread [Next in Thread]