lmi-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lmi-commits] [lmi] master 6ecceb5 4/6: Rename a local variable for clar


From: Greg Chicares
Subject: [lmi-commits] [lmi] master 6ecceb5 4/6: Rename a local variable for clarity
Date: Thu, 5 Jan 2017 21:52:29 +0000 (UTC)

branch: master
commit 6ecceb58435ccfdc1ba23547c02dd3befc7f4e11
Author: Gregory W. Chicares <address@hidden>
Commit: Gregory W. Chicares <address@hidden>

    Rename a local variable for clarity
    
    A verb phrase is a poor variable name. That it's copied from examples
    in the C99 standard [7.6.4.4/4; F.9.6.6/2] is no excuse.
---
 fenv_lmi.cpp |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/fenv_lmi.cpp b/fenv_lmi.cpp
index ccabf8e..8e0cb1d 100644
--- a/fenv_lmi.cpp
+++ b/fenv_lmi.cpp
@@ -65,8 +65,8 @@ void fenv_initialize()
 #if defined LMI_X87
     x87_control_word(default_x87_control_word());
 #else  // !defined LMI_X87
-    std::fenv_t save_env;
-    std::feholdexcept(&save_env);
+    std::fenv_t saved_env;
+    std::feholdexcept(&saved_env);
     std::fesetround(FE_TONEAREST);
     // Standard C++ provides no way to set hardware precision.
     // Here is an example of a C99 7.6/9 extension that controls



reply via email to

[Prev in Thread] Current Thread [Next in Thread]