lwip-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-devel] Last changes by Marc


From: Frédéric BERNON
Subject: [lwip-devel] Last changes by Marc
Date: Fri, 17 Aug 2007 12:44:42 +0200

Some notes about last changes by Marc Boucher. We have talk yesterday with him about some of these changes.
 
- "Add a different memp pool for MEMP_NUM_TCPIP_MSG_API & MEMP_NUM_TCPIP_MSG_INPKT". I'm in flavor of this change, since it avoid problems when we receive lot of packets (or when we got a DoS attack). Perhaps "INPKT" is not so clear. "INPACKET"? (it's a detail of course).
 
- "pbuf": split the flags fields in flags & type don't cause me any problems (except I would rename "flgs" in "flags"). PBUF_FLAG_LINK_BROADCAST is not used (it wasn't before this change). I propose to remove it.
 
- "PBUF_FLAG_PUSH": don't cause me any problem, but it's only used by socket layer. If we add LWIP_SOCKET option, we can use it to disable the code in tcp_in.c if anyone want.
 
- "PPPoE": I like having such features, more if Marc can take time to study opened items in the bugtracker for PPP ;)
 
- "tcpip.c / ETHARP_TCPIP_INPUT / ETHARP_TCPIP_ETHINPUT": No problem, but, to be honest, I'm in flavor to remove ETHARP_TCPIP_INPUT & ETHARP_TCPIP_ETHINPUT option, and to only support "ETHINPUT" case. It will simplify the code, and is the only way to have no concurrent access in ARP module. No objects to change that?
 
- "tcpip.c / TCPIP_MSG_TIMEOUT": this part increase for evryone the footprint (even if you don't use pppoe, your linker should remove tcpip_timeout, but not the part in the main loop's switch). Add option?
 
- "sockets.c / check netconn_peer": I don't see no case where netconn_peer should return an error. It's increase the footprint, so, is it really useful (do you already have the case with cvs head code)?
 
- "sockets.c / lwip_recvfrom": I don't have test it, and for me it should be ok, but, it change the behavior of the function: before, the function return when it add processed a netbuf. Now, it wait until got "len" bytes. I note this is in this case that PBUF_FLAG_PUSH is used.
 
- #include "netif/ppp_oe.h": it's done in ethernetif.c & tcpip.h. before, we should not have the ppp folder to build. Now, it's mandatory. It's just a remark.
 
- "mem / mem_calloc" : no problem with that.
 
- Of course Marc, if you can thought to update the CHANGELOG (mainly for MEMP_NUM_TCPIP_MSG_API & MEMP_NUM_TCPIP_MSG_INPKT), and to replace tabs by spaces, and to use the same ident that the other part of the code, it would be nice... :)
I will be far of Internet until monday, so, don't worry if I don't answer...
 
 
====================================
Frédéric BERNON
HYMATOM SA
Chef de projet informatique
Microsoft Certified Professional
Tél. : +33 (0)4-67-87-61-10
Fax. : +33 (0)4-67-70-85-44
Email : address@hiddenr
Web Site : http://www.hymatom.fr
====================================
P Avant d'imprimer, penser à l'environnement
 
 

Attachment: Frédéric BERNON.vcf
Description: Frédéric BERNON.vcf


reply via email to

[Prev in Thread] Current Thread [Next in Thread]