octave-bug-tracker
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #41977] '__qt_ginput__' not found


From: Andreas Weber
Subject: [Octave-bug-tracker] [bug #41977] '__qt_ginput__' not found
Date: Thu, 31 Jul 2014 21:15:57 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 Iceweasel/30.0

Follow-up Comment #2, bug #41977 (project octave):

This should be easy to fix: Because __fltk:ginput__.m makes only use of
figure::properties::callbacks and they are alreay implemented for qt, a quick
hack&dirty to override the toolkit in ginput.m

+++ b/scripts/plot/util/ginput.m        Thu Jul 31 23:05:07 2014 +0200
@@ -43,7 +43,7 @@
   a = gca ();  # Create an axis, if necessary
   drawnow ();
   toolkit = get (f, "__graphics_toolkit__");
+toolkit = "fltk";
   varargout = cell (1, nargout);


makes ginput usable (but BUTTONS is empty) in the GUI with graphics_toolkit
qt.


>> graphics_toolkit
ans = qt
>> plot(1:10)
>> [X, Y, BUTTONS] = ginput (3)
X =

   1.7558
   3.8525
   6.2258

Y =

   1.7558
   3.8525
   6.2258

BUTTONS = [](0x0)


This leads to a question for the final implementation: How should we rename
scripts which works for fltk and qt (for example __fltk_ginput__.m)?

Sould we use "opengl" for both toolkits (__opengl_ginput__)? On the other hand
there is nothing special to qt, fltk or opengl in these scripts. They use
figure and axes callbacks which should be available to all toolkits.

Btw, in scripts/gui/private we have a different naming scheme: There is is
__[basefunction]_[graphics_toolkit]__.m and in plot/util/private/ it is
__[graphics_toolkit]_[basefunction]__.m

-- Andy

    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/bugs/?41977>

_______________________________________________
  Nachricht gesendet von/durch Savannah
  http://savannah.gnu.org/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]