[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #43651] special character (diameter sign) in p

From: H. G.
Subject: [Octave-bug-tracker] [bug #43651] special character (diameter sign) in plot produces warning or doesn't show up
Date: Thu, 27 Nov 2014 20:33:06 +0000
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0

Follow-up Comment #2, bug #43651 (project octave):

I've tried a couple of things as suggested, and here is my current conclusion
(more details below) for this one problematic Windows installation of Octave:

* With FLTK as graphics toolkit, the default font does not contain several
special characters, so there are not printed on screen (and a useful warning
message is issued).

* With FLTK and GNUPLOT as graphics toolkit, a (in this case useless) warning
message is issued when printing those special characters, even when the on
screen printing acutually DOES work properly.

Here are some details you wanted to know:

* The GNUPLOT VERSION is "Version 4.4 patchlevel 3, last modified March 2011,
System: MS-Windwos 32 bit". This seems to be included in the MXE Windows
installation from mxeoctave.osuv.de.

* I didn't find any way to find out the actual name of the DEFAULT FONT used
by Octave, gnuplot or fltk. Can you give me a hint how I can get this

* With GNUPLOT I tried some different font names like this:

graphics_toolkit gnuplot
text (0.5,0.5, 'A   B', 'fontname', '*')
text (0.5,0.5, 'A   B', 'fontname', 'arial')
text (0.5,0.5, 'A   B', 'fontname', 'times')

The result was: The diamater sign always IS printed properly. The only problem
with gnuplot is, that an unnecessary warning message is issued.

* With FLTK I also tried some font names:

graphics_toolkit fltk
text (0.5,0.5, 'A   B', 'fontname', '*')
text (0.5,0.5, 'A   B', 'fontname', 'arial')
text (0.5,0.5, 'A   B', 'fontname', 'times')

The result was: The diameter sign is NOT printed with many font names I have
tried. A (some times different number of) warning messages are issued, which
is appropriate in this case.

* With FLTK I did find one font name that does work:
graphics_toolkit fltk
text (0.5,0.5, 'A   B', 'fontname', 'cambria')

With this font (maybe there are other ones that do work, but I did try a
couple of them) the diameter sign IS properly displayed on screen. But still
the unecessary warning message is issued (like with Gnuplot).

As said at the beginning, I suspect this whole issue is "only" about a change
in the default font name, that Octave tries to use. Can this happen? How do I
find out which font name Octave is using as default font?


Reply to this item at:


  Nachricht gesendet von/durch Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]