octave-maintainers
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Renaming src/


From: Daniel J Sebald
Subject: Re: Renaming src/
Date: Tue, 14 Aug 2012 17:19:47 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.24) Gecko/20111108 Fedora/3.1.16-1.fc14 Thunderbird/3.1.16

On 08/14/2012 04:58 PM, Rik wrote:
On 08/14/2012 01:39 PM, address@hidden wrote:
Message: 6
Date: Tue, 14 Aug 2012 13:54:27 -0500
From: Daniel J Sebald<address@hidden>
[snip]
2) The "fcn" is almost a redundancy, unless the implication is that
there is some function in Octave called "core" and some function inside
Octave called "interp".  Otherwise, if it just means inside the
directory are some functions related to "core", for example, then what
else would the programmer think is in there if it were just "src/core"?
3) There's "corefcn", there's "interpfcn", and then there's a
combination of the two "interp-core".  Perhaps that's correct, but on
first read it makes one pause.
There are some reasons for this.  "interp-core" is for code which is at the
heart of the interpreter and which does not export any user visible
functions.  "interpfcn" is for code that has functions the user can see
such as warning() or dbstop().  "corefcn" is for functions which are at the
heart of mathematical analysis, such as inv() or eig(), but which aren't
related to the interpreter.  Lastly "dldfcn" is for dynamically loaded
functions.  I'm open to a better naming scheme as long as the distinctions
that have currently been made can still be made.

OK, probably John is the best to weigh in on that since it is a small group that knows the interpreter real well. I'll just toss out some words here

Code which is at the heart of the interpreter:
interp/core
coreintrp

Code that has functions the user can see such as warning() or dbstop():
interp/base
baseintrp
interp/fund
fundintrp
interp/mech (mechanics)
mechintrp

Functions which are at the heart of mathematical analysis:
math
mathcore
mathbase

I welcome any more ideas.


The other hyphenated directories--"octave-value", "template-inst",
"parse-tree"--come from trying to be specific about what is in them without
using CamelCase.  Since spaces aren't good, and jwe prefers hyphens over
underscores, that is what we came up with.

octave-value is the one that sort of makes sense to me because it coincides with the all-important octave_value class. "template-inst" might be fine as just "template" or "tmplt". Is there something important about the "inst", which I assume means instance or instantiation?

Dan


reply via email to

[Prev in Thread] Current Thread [Next in Thread]