This chapter provides a description of the graphical user interface.

Introduction to the Graphical User Interface

The PSPP graphical user interface provides a set of windows through which you store, edit and analyze data. You can choose to perform tasks and operations through interactive drop down menus in the data editor window or through command line statements entered in the syntax editor. The three primary windows include the Data Editor, Syntax Editor, and the Output Viewer. 
Primary PSPP Windows
Data Editor
The data editor window is central to PSPP and launches when you start a session. This window is similar in organization to a spreadsheet, where data is stored and edited in columns and rows of cells. 
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Syntax Editor
The syntax editor window is where you enter command line instructions to edit, import and analyze data. This has the advantage of enabling batch processing and code reuse. You can launch the syntax editor from the data editor window by selecting File->Open->Syntax.
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Output Viewer

This window pops up after the execution of an instruction set and displays the instructions executed and results of statistical analyses including, text, tables, and charts. 

Data Editor Window
The data editor has two views; data view shows the numerical value held by each datum and variable view displays the metadictionary data of each variable.  You can toggle between the two views by clicking on the “Data View” or “Variable View” tab at the bottom left hand corner of the data editor. 
Data View

Data view adheres to a strict data layout format. Rows represent cases, and each column represents a measured variable. For example, in the hotel customer, satisfaction survey shown in figure x. each row represents the set of answers given by a specific respondent and each column represents a specific question. 

Data View of a Hotel Customer Satisfaction Survey
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Variable View
Variable view shows all the variable attributes associated with each case as the following variable view of a hotel customer-satisfaction survey demonstrates. Variable attributes include name, type, width, decimal, variable label, value label, missing values, columns, align, and measurement. See section x(FIND FOR CURRENT) for a description of each attribute.
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Variable Attributes
(Elsewhere I have referenced the current manual where needed but with this section describing variable attributes I have reprinted the descriptions from the current manual, in the order presented in the data editor window.  The definitions are relevant to the data editor window so I thought perhaps they could be reprinted in this section as it might otherwise prove awkward to the reader since it’s going to be a linear pdf document.)

Name 

A name is an identifier, up to 64 bytes long. Each variable must have a different name.

Some system variable names begin with ‘$’, but user-defined variable names may not begin with ‘$’.

The final character in a variable name should not be ‘.’, because such an identifier will be misinterpreted when it is the final token on a line: FOO. will be divided into two separate tokens, ‘FOO’ and ‘.’, indicating end-of-command.  
The final character in a variable name should not be ‘_’, because some such identifiers are used for special purposes by PSPP procedures.

As with all PSPP identifiers, variable names are not case-sensitive. PSPP capitalizes variable names on output in the same way you define the variable. 
Type 

Numeric or string.
Width 

This is for string variables only. String variables with a width of 8 characters or fewer are called short string variables. Short string variables are used in many procedures where long string variables (those with widths greater than 8) are not allowed.

Certain systems may consider strings longer than 8 characters to be short strings. Eight characters is the minimum figure for the maximum length of a short string. 
Decimal

An optional parameter used for input and output formats that gives the number of decimal places, and has the value zero if not set.
Variable label

A string that describes the variable.

Value label

These are optional and associate each possible value of the variable with a string.

Missing values

These are optional and up to three values, or a range of values, or a specific value plus a range, can define user-missing values. PSPP assigns a system-missing value to an observation when there is no other obvious value for that observation. Observations with missing values are not included in analyses.  User-missing values are actual data values, while the system-missing value is not a value at all.

Columns
A parameter used for input and output formats that specifies the field width in columns.

Measurement 

States whether the measurement level is nominal, ordinal, or scale. 
Data Entry and Editing
New Variable

You can enter a new variable into the data editor by either selecting insert variable from the edit drop down menu or the tool bar. Refer to section x. These functions insert a new blank variable with a generic name. 
If you already have at least one variable defined, you can also add a new variable to the left of the current column by right clicking on the variable title and selecting insert variable from the pop-up menu.
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Edit Variable Attributes

You can edit variable attributes such as Name, Type, Width, Decimals, Label, and Values, Missing, Columns, Align, and Measure move in variable view.
[image: image6.jpg]Fle Edit View Data Iransform Analyze Utiities Windows Help

B = S ] 3 = ®
Open Variables Find Insert Variable | Split File  Weight Cases Value Labels

\ Width \ Decimals \ Label \ Values \ Missing \ Columns \ Align \ Measure
1

s 2 None None s Right |Scale





Name
Click the cell under Name, type the new name and press the enter key.

Type

Click the cell under Type, and then click on the grey box that appears to bring up a Variable Type dialogue box.
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Variable types include Numeric, Comma, Dot, Scientific notation, Date, Dollar, Custom currency, and String.  Refer to section x. 

Width
Click on the cell in the Width column and select the up-down arrow that appears to alter the value. Refer to section x. 
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Decimals 
Click on the cell in the Decimals column and select the up-down arrow that appears to alter the value. Refer to section x.
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Label
Click the cell in the Label column, type the variable label, and then press enter.
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Values

Click the cell in the Values column, and then click the gray box that appears to bring up the Value Labels dialogue box. Refer to section x.
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Enter the Value in the Value box and the associated label for the Value Label, click the Add button and select OK.
Missing

Select the cell in the Missing column and the click the gray box that appears to bring up the Missing Values dialogue box. 
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You can either enter up to three discrete missing values or specify a numerical range plus one discrete value. Refer to section x.
Columns

Click the cell under Columns and then click the up-down arrows that appear to alter the value. Refer to section x.
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Align

Align values left, right or center in a cell. Click the cell in the Align column, and then select left, right, or center from the drop down menu that appears.
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Measure

Select the cell in the Measure column, and then choose nominal, ordinal, or scale from the drop down menu that appears. Refer to section x.
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New Case
You can add a new case to an existing variable by either selecting Insert Cases from the drop down menu or the tool bar (see section x). Alternatively, you can you can right click the row number above the location where the new case is to be inserted and select insert new case from the pop-up menu. 
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Read Variable Label in Data View

Hover the mouse over the variable title at the top of the column to view its label.
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Change Data Value

In data view, select the cell with the value you want to change, type the new value over it and press enter.
Clear Variables

You can delete the current column by selecting it and either choosing clear variable from the edit drop down menu (link to menu) or by right clicking on the column title and selecting clear variable from the pop-up menu.
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Clear Cases

You can delete the current case by right clicking on the row number and selecting delete cases from the pop-up menu.
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Sort Cases

You can sort cases by right clicking on the variable title and selecting Ascending or Descending from the pop-up menu in addition to selecting Sort Cases from the Data drop down menu (see section x).
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Status Bar

Located at the bottom of the data editor window, it provides information about the data you are currently processing. 
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Filter Status

This turns on when you filter a subset of cases in the current file for analysis. (Note appears non functional right now)

Weight Status

States which variable you are weighting the data against in the analysis. 

Split File Status

Indicates you have separated select data into different groups for analysis.

Main Menu and Tool Bar  
You can perform tasks and operations on the data in the data editor window through a group of menus and a toolbar. Refer to section x.
Main Menu

File

Performs all file handling operations such opening, closing and saving files.

Edit

Moves data and text around through standard cut, copy, and paste operations, inserts data and cases and performs searches. 

View

Enables the data editor to display extra information such as a status bar and value labels, switch data editor views, and change the font. 

Data

Performs operations on data sets such as sort, transpose, apply weights, extract subsets of cases, and split files.

Transform

Replaces targeted data with the result of applying mathematical or other operations to it. 

Analyze

Perform statistical analyses on the data.   

Utilities

Provides variable information and enables you to add comments. 

Windows

Enables you to toggle between open windows, split and minimize them.

Help

Provides help contents.

Output Viewer

The output viewer displays results, charts, and the instruction set executed, whether invoked from a menu command or the syntax window.
Note, that the output viewer is not visible when PSPP loads. It first appears after you execute a set of instructions.
Examples
Output viewer displays the last set of instructions executed.

1)
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2)
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When displaying results, the right pane of the window shows tables, text, and charts. The left pane gives a corresponding outline.

Example
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Save Output Viewer Contents

To save the results in the output viewer select File->Export. File types include PDF, HTML, Open Document, Text, and Postscript. 

Syntax Editor Window

Use the Syntax Editor window to create lines of command instructions for execution and reuse. For command syntax and rules see section x.
You can enter commands into the syntax window and then execute them by selecting run from the menu. In addition, you can save the instruction set into a file for later reuse. For example, the following set of commands generates a list of random numbers in the data editor.
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Enter Syntax
1) Most data-editor-menu functions able you to paste the equivalent command line directly to a syntax window from the dialogue box by selecting the paste button.
Example

Place a command line instruction that generates descriptive statistics in the syntax editor window.

Select Analyze -> Descriptive Statistics -> Descriptives (refer to section x)
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Select the desired variables and statistics in the Descriptives dialogue box.

Click the Paste button. 
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Run 

Select run to execute code in the syntax window.

             Options include:

                              Run->All        

Execute all commands.
                              Run->Selection                 Execute highlighted commands.

                              Run->Current Line    
Execute line at current cursor position. 

                              Run->To End                    Execute at cursor position onwards.
Save
You can save the set of commands in a syntax file by selecting File->Save or File->Save As from the menu.
Example  (Leave this out for now)
1) Select File->New Syntax File in the Data Editor Window to bring up a syntax editor window.

2) Enter the following text into the window, and place the lines following the ONEWAY command at one tab stop position from the beginning of the line.
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2) Execute the statements by selecting Run->All from the drop down menu. 
The output viewer window displays the results.
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3) Save the file by selecting File->Save As.

