qemu-block
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH v3 11/32] blockdev: Move qed probe to its own fi


From: Max Reitz
Subject: Re: [Qemu-block] [PATCH v3 11/32] blockdev: Move qed probe to its own file
Date: Wed, 6 Jul 2016 17:16:45 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.1.1

On 05.07.2016 17:24, Colin Lord wrote:
> Isolate qed probe as part of the modularization process.
> 
> Signed-off-by: Colin Lord <address@hidden>
> ---
>  block/Makefile.objs   |  2 +-
>  block/probe/qed.c     | 18 ++++++++++++++++++
>  block/qed.c           | 15 +--------------
>  include/block/probe.h |  1 +
>  4 files changed, 21 insertions(+), 15 deletions(-)
>  create mode 100644 block/probe/qed.c

Reviewed-by: Max Reitz <address@hidden>

> diff --git a/include/block/probe.h b/include/block/probe.h
> index f9dd36e..e3e9934 100644
> --- a/include/block/probe.h
> +++ b/include/block/probe.h
> @@ -9,5 +9,6 @@ int dmg_probe(const uint8_t *buf, int buf_size, const char 
> *filename);
>  int parallels_probe(const uint8_t *buf, int buf_size, const char *filename);
>  int qcow_probe(const uint8_t *buf, int buf_size, const char *filename);
>  int qcow2_probe(const uint8_t *buf, int buf_size, const char *filename);
> +int bdrv_qed_probe(const uint8_t *buf, int buf_size, const char *filename);

Hmmm, maybe it would make sense to follow a consistent naming scheme
here, i.e. either ${format}_probe() or bdrv_${format}_probe(). The
latter is probably better, but the former is what most formats do, so...

But maybe that is something that should be done in the "Separate X probe
from its driver" patches.

Max

>  
>  #endif
> 


Attachment: signature.asc
Description: OpenPGP digital signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]