qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 4/4] pci: use pci_config_header in pci.c


From: Anthony Liguori
Subject: Re: [Qemu-devel] [PATCH 4/4] pci: use pci_config_header in pci.c
Date: Wed, 01 Oct 2008 14:27:47 -0500
User-agent: Thunderbird 2.0.0.16 (X11/20080723)

Gerd Hoffmann wrote:
Anthony Liguori wrote:
I'm not sure what you are expecting here. The idea to introduce
gcc-checkable byteordered types (via struct trick) was rejected.  So I
have le32 & friends just typedef'ed to the corrosponding int*_t types
and use the existing cpu_*() byteorder macros.  The new types are
basically documentation now.

Endian swapping must still be done by the users.  Lots of casts can be
dropped though, which IMHO improves the readability alot (random chunk
picked from patch):

-    cmd = le16_to_cpu(*(uint16_t *)(d->config + PCI_COMMAND));
+    cmd = le16_to_cpu(conf->command);

I'm not aware of any way to do the byteswapping here automatically.

Because the config structure is loaded after pci_register device and because the MMIO callbacks into the config space? If you look at pci_default_read_config(), it actually does conversion from le to host CPU because that's what MMIO callbacks expect. If you simply removed this, it would work. Of course, you'll have to audit each caller of pci_register_device() and make sure their config's get changed too.

Regards,

Anthony LIguori

Except maybe introducing accessor functions/macros for each and every
struct element and hide the byteswapping macro call therein.  Which in
turn makes providing the struct to pci drivers sort of pointless ...

cheers,
  Gerd





reply via email to

[Prev in Thread] Current Thread [Next in Thread]