qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 2/5] Introduce new helper function qcow_shedule_


From: Gleb Natapov
Subject: Re: [Qemu-devel] [PATCH 2/5] Introduce new helper function qcow_shedule_bh().
Date: Mon, 24 Nov 2008 22:05:58 +0200

On Mon, Nov 24, 2008 at 10:32:53AM -0600, Anthony Liguori wrote:
> Gleb Natapov wrote:
>> Use it to remove code duplications from qcow_aio_read_cb().
>>
>> Signed-off-by: Gleb Natapov <address@hidden>
>> ---
>>
>>  block-qcow2.c |   44 +++++++++++++++++---------------------------
>>  1 files changed, 17 insertions(+), 27 deletions(-)
>>
>> diff --git a/block-qcow2.c b/block-qcow2.c
>> index ab19a4e..69f6414 100644
>> --- a/block-qcow2.c
>> +++ b/block-qcow2.c
>> @@ -1177,6 +1177,20 @@ static void qcow_aio_read_bh(void *opaque)
>>      qcow_aio_read_cb(opaque, 0);
>>  }
>>  +static int qcow_shedule_bh(QEMUBHFunc *cb, QCowAIOCB *acb)
>> +{
>> +    if (acb->bh)
>> +        return -EIO;
>> +
>> +    acb->bh = qemu_bh_new(cb, acb);
>> +    if (!acb->bh)
>> +        return -EIO;
>> +
>> +    qemu_bh_schedule(acb->bh);
>> +
>> +    return 0;
>> +}
>> +
>>  static void qcow_aio_read_cb(void *opaque, int ret)
>>  {
>>      QCowAIOCB *acb = opaque;
>> @@ -1232,30 +1246,14 @@ fail:
>>                  if (acb->hd_aiocb == NULL)
>>                      goto fail;
>>              } else {
>> -                if (acb->bh) {
>> -                    ret = -EIO;
>> -                    goto fail;
>> -                }
>> -                acb->bh = qemu_bh_new(qcow_aio_read_bh, acb);
>> -                if (!acb->bh) {
>> -                    ret = -EIO;
>> +                if((ret = qcow_shedule_bh(qcow_aio_read_bh, acb)) < 0)
>>   
>
> Please do this on two lines and watch the whitespace damage.  Also, you  
OK.

> have a consistent typo in "schedule".
>
That is only one typo and many cut and pastes :)

--
                        Gleb.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]