qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [6336] DisplayState interface change (Stefano Stabellin


From: C . W . Betts
Subject: Re: [Qemu-devel] [6336] DisplayState interface change (Stefano Stabellini)
Date: Thu, 15 Jan 2009 23:00:18 -0700

This patch completely breaks the cocoa front end.  The cocoa end either needs to be re-written. I will see what I can do, however, I am not skilled in writing such code.
On Jan 15, 2009, at 3:14 PM, Anthony Liguori wrote:

Revision: 6336
         http://svn.sv.gnu.org/viewvc/?view=rev&root=qemu&revision=6336
Author:   aliguori
Date:     2009-01-15 22:14:11 +0000 (Thu, 15 Jan 2009)

Log Message:
-----------
DisplayState interface change (Stefano Stabellini)

This patch changes the DisplayState interface adding support for
multiple frontends at the same time (sdl and vnc) and implements most
of the benefit of the shared_buf patch without the added complexity.

Currently DisplayState is managed by sdl (or vnc) and sdl (or vnc) is
also responsible for allocating the data and setting the depth.
Vga.c (or another backend) will do any necessary conversion.

The idea is to change it so that is vga.c (or another backend) together
with console.c that fully manage the DisplayState interface allocating
data and setting the depth (either 16 or 32 bit, if the guest uses a
different resolution or is in text mode, vga.c (or another backend) is
in charge of doing the conversion seamlessly).

The other idea is that DisplayState supports *multiple* frontends
like sdl and vnc; each of them can register some callbacks to be called
when a display event occurs.

The interesting changes are:

- the new structures and related functions in console.h and console.c

in particular the following functions are very helpful to manage a
DisplaySurface:

qemu_create_displaysurface
qemu_resize_displaysurface
qemu_create_displaysurface_from
qemu_free_displaysurface

- console_select and qemu_console_resize in console.c
this two functions manage multiple consoles on a single host display

- moving code around in hw/vga.c
as for the shared_buf patch this is necessary to be able to handle a dynamic
DisplaySurface bpp

- changes to vga_draw_graphic in hw/vga.c
this is the place where the DisplaySurface buffer is shared with the
videoram, when possible;


Compared to the last version the only changes are:

- do not remove support to dpy_copy in cirrus_vga
- change the name of the displaysurface handling functions

Signed-off-by: Stefano Stabellini <address@hidden>
Signed-off-by: Anthony Liguori <address@hidden>

Modified Paths:
--------------
   trunk/console.c
   trunk/console.h
   trunk/curses.c
   trunk/hw/cirrus_vga.c
   trunk/hw/nseries.c
   trunk/hw/palm.c
   trunk/hw/vga.c
   trunk/hw/vga_int.h
   trunk/qemu-common.h
   trunk/sdl.c
   trunk/vl.c
   trunk/vnc.c


reply via email to

[Prev in Thread] Current Thread [Next in Thread]