qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 06/14] Rename SLIRP_OBJS to slirp-obj-y


From: Mark McLoughlin
Subject: Re: [Qemu-devel] [PATCH 06/14] Rename SLIRP_OBJS to slirp-obj-y
Date: Thu, 25 Jun 2009 07:59:25 +0100

On Thu, 2009-06-25 at 00:08 +0200, address@hidden wrote:

> diff --git a/Makefile b/Makefile
> index 802d276..d316388 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -188,10 +188,10 @@ endif
> 
>  ifdef CONFIG_SLIRP
>  CPPFLAGS+=-I$(SRC_PATH)/slirp
> -SLIRP_OBJS=cksum.o if.o ip_icmp.o ip_input.o ip_output.o \
> -slirp.o mbuf.o misc.o sbuf.o socket.o tcp_input.o tcp_output.o \
> -tcp_subr.o tcp_timer.o udp.o bootp.o debug.o tftp.o
> -OBJS+=$(addprefix slirp/, $(SLIRP_OBJS))
> +slirp-obj-y = cksum.o if.o ip_icmp.o ip_input.o ip_output.o
> +slirp-obj-y += slirp.o mbuf.o misc.o sbuf.o socket.o tcp_input.o tcp_output.o
> +slirp-obj-y += tcp_subr.o tcp_timer.o udp.o bootp.o debug.o tftp.o
> +OBJS+=$(addprefix slirp/, $(slirp-obj-y))

I like the whole series, but I think I'd drop this change and the
XEN_OBJS change.

We won't be individually configuring out any of SLIRP_OBJS, so an end
result like:

  obj-$(CONFIG_SLIRP) += $(addprefix slirp/, $(SLIRP_OBJS))

seems nicer to me than:

  obj-$(CONFIG_SLIRP) += $(addprefix slirp/, $(slirp-obj-y))

Cheers,
Mark.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]