qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 00/46] More configure/Makefile cleanups


From: Juan Quintela
Subject: [Qemu-devel] [PATCH v2 00/46] More configure/Makefile cleanups
Date: Fri, 24 Jul 2009 20:30:00 +0200

Hi

Changes from previous version:
- Changes to LIBS variable are gone (will be done in a different way)
- config-host.h generated from config-host.mak
- Almost everything configurable starts with:
  - TARGET_*
  - HOST_*
  - CONFIG_*
- don't repeat libs name, use the same libraries in detection and in
  Makefiles (in some cases that was not true)
- CONFIG_NOWIN32 is called CONFIG_POSIX
- sdl configuration is basically sane now
- AUDIO_DRIVERS define is gone, done in audio.c with #ifdefs
  AUDIO_DRIVERS was a hack that is quite complicated to generate through
  the Makefile.

Comments?

Later, Juan.

Juan Quintela (46):
  change HOST_SOLARIS to CONFIG_SOLARIS{_VERSION}
  Remove SP_CFLAGS and SP_LDFLAGS
  target_arch2 is redefined unconditionally later
  remove CONFIG_ from VNC_TLS_{LIBS,FLAGS}
  use same algorithm for testing  and
  remove CONFIG_ from VNC_SASL_{LIBS,FLAGS}
  remove CONFIG_ from BLUEZ_{LIBS,FLAGS}
  make fmod also use FMOD_{LIBS,CFLAGS}
  make oss use OSS_LIBS
  move printing of config-host.mak variables to end of generation
  more specific config.mak can overwrote more general config.mak
  Add -static in configure if needed
  Rename HAVE_FDT to CONFIG_FDT and define it also in Makefile
  Refactor code to remove one #ifdef CONFIG_FDT
  fix indententation
  O_LARGEFILE is already set in qemu-common.h
  rename HOST_BSD to CONFIG_BSD
  define MAP_ANONYMOUS if it is not defined in qemu-common.h
  rename HAVE_PREADV to CONFIG_PREADV
  rename HAVE_IOVEC to CONFIG_IOVEC
  rename HAVE_FNMATCH_H to CONFIG_FNMATCH
  rename HAVE_MACHINE_BSWAP_H to CONFIG_MACHINE_BSWAP_H
  rename HAVE_BYTESWAP_H to CONFIG_BYTESWAP_H
  rename DEBUG_TCG to CONFIG_DEBUG_TCG
  rename DEBUG_EXEC to CONFIG_DEBUG_EXEC
  rename WORDS_BIGENDIAN to CONFIG_WORDS_BIGENDIAN
  Add CONFIG_POSIX
  Use CONFIG_POSIX to simplify Makefile
  the else part of this test is obsolete We are testing for sdl = yes
    inside the else part of the test if sdl = yes
  sdl_config value was always sdl-config
  Calculate sdl_libs and sdl_flags and use them everywhere
  instead of setup sdl_x11 just add -lX11 to sdl_libs
  target_softmmu is undefined at that point
  remove sdl_static.  Just do the right thing if static is yes
  indent with 2 spaces sdl tests
  Define and use xen libs in a single place
  simplify curses library selection
  simplify brlapi selection
  simplify vde libs selection
  simplify fdt libs selection
  test if xen is enabled only once
  define ENOTSUP the same that the other errors
  rename NEEDS_LIBSUNMATH to CONFIG_NEEDS_LIBSUNMATH
  rename USE_NPTL to CONFIG_USE_NPTL
  Remove AUDIO_DRIVERS define
  Generate config-host.h from config-host.mak

 Makefile                           |   35 +---
 Makefile.hw                        |    2 +-
 Makefile.target                    |   53 ++----
 acl.c                              |    4 +-
 audio/audio.c                      |   25 +++-
 audio/audio.h                      |    2 +-
 block.c                            |    4 +-
 block/raw-posix.c                  |    4 +-
 bsd-user/mmap.c                    |    2 +-
 bsd-user/qemu.h                    |    6 +-
 bsd-user/syscall.c                 |    6 +-
 bswap.h                            |   12 +-
 configure                          |  382 ++++++++++++++++--------------------
 console.c                          |    8 +-
 cpu-all.h                          |   12 +-
 cpu-defs.h                         |    2 +-
 cpu-exec.c                         |   16 +-
 create_config                      |   49 ++++-
 disas.c                            |    2 +-
 dyngen-exec.h                      |    4 +-
 exec.c                             |    2 +-
 fpu/softfloat-native.c             |   15 +-
 fpu/softfloat-native.h             |   11 +-
 fpu/softfloat.h                    |    6 +-
 gdbstub.c                          |    2 +-
 hw/blizzard_template.h             |    2 +-
 hw/bt-hci.c                        |    2 +-
 hw/gus.c                           |    2 +-
 hw/omap_lcd_template.h             |    2 +-
 hw/petalogix_s3adsp1800_mmu.c      |    8 +-
 hw/pl110_template.h                |    6 +-
 hw/ppc440_bamboo.c                 |    2 +-
 hw/ppce500_mpc8544ds.c             |    4 +-
 hw/pxa2xx_template.h               |    2 +-
 hw/vga.c                           |   14 +-
 hw/vga_template.h                  |    6 +-
 kqemu.c                            |    2 +-
 linux-user/arm/nwfpe/double_cpdo.c |    4 +-
 linux-user/arm/nwfpe/fpa11_cpdt.c  |    4 +-
 linux-user/main.c                  |    6 +-
 linux-user/mmap.c                  |    2 +-
 linux-user/qemu.h                  |    8 +-
 linux-user/syscall.c               |   26 ++--
 loader.c                           |    4 +-
 net.c                              |    6 +-
 osdep.c                            |   12 +-
 posix-aio-compat.c                 |    4 +-
 qemu-char.c                        |    2 +-
 qemu-common.h                      |   13 +-
 qemu-lock.h                        |    2 +-
 savevm.c                           |    4 +-
 sdl.c                              |    4 +-
 slirp/ip.h                         |    6 +-
 slirp/slirp_config.h               |    2 +-
 slirp/tcp.h                        |    2 +-
 target-arm/neon_helper.c           |    2 +-
 target-i386/cpu.h                  |    2 +-
 target-i386/exec.h                 |    2 +-
 target-i386/translate.c            |    4 +-
 target-mips/cpu.h                  |    4 +-
 target-ppc/kvm_ppc.c               |    2 +-
 target-ppc/op_helper.c             |   30 ++--
 target-ppc/translate.c             |    4 +-
 target-ppc/translate_init.c        |    4 +-
 target-sparc/op_helper.c           |    2 +-
 tcg/arm/tcg-target.c               |    2 +-
 tcg/sparc/tcg-target.h             |    2 +-
 tcg/tcg.c                          |    2 +-
 tcg/tcg.h                          |    2 +-
 vl.c                               |    6 +-
 vnc.c                              |    2 +-
 71 files changed, 442 insertions(+), 459 deletions(-)





reply via email to

[Prev in Thread] Current Thread [Next in Thread]