qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH 18/25] pci: add helper functions for pci config


From: Michael S. Tsirkin
Subject: [Qemu-devel] Re: [PATCH 18/25] pci: add helper functions for pci config write function.
Date: Sun, 4 Oct 2009 12:30:26 +0200
User-agent: Mutt/1.5.19 (2009-01-05)

On Sat, Oct 03, 2009 at 05:16:10AM +0900, Isaku Yamahata wrote:
> add helper functions for pci config write function to check
> if its configuration space is changed..
> Those function will be used later.
> 
> Signed-off-by: Isaku Yamahata <address@hidden>
> ---
>  hw/pci.h |   44 ++++++++++++++++++++++++++++++++++++++++++++
>  1 files changed, 44 insertions(+), 0 deletions(-)
> 
> diff --git a/hw/pci.h b/hw/pci.h
> index 3ea5258..ec989f0 100644
> --- a/hw/pci.h
> +++ b/hw/pci.h
> @@ -400,6 +400,50 @@ static inline uint32_t pcie_config_size(PCIDevice *d)
>      return pci_is_pcie(d)? PCIE_CONFIG_SPACE_SIZE: PCI_CONFIG_SPACE_SIZE;
>  }
>  
> +static inline uint8_t *pci_write_config_init(PCIDevice *d,
> +                                             uint32_t addr, int len)
> +{
> +    uint8_t *orig = qemu_malloc(pcie_config_size(d));
> +    memcpy(orig + addr, d->config + addr, len);
> +    return orig;
> +}
> +
> +static inline void pci_write_config_done(uint8_t *orig)
> +{
> +    qemu_free(orig);
> +}

Let's just put orig array inside PCIDevice structure,
and then we don't need to malloc/free on each config cycle.
The memcpy call can then be open-coded.

> +static inline int pci_config_changed(const uint8_t *orig, const uint8_t *new,
> +                                     uint32_t addr, uint32_t len,
> +                                     uint32_t base, uint32_t end)
> +{
> +    uint32_t low = MAX(addr, base);
> +    uint32_t high = MIN(addr + len, end);
> +
> +    /* check if [addr, addr + len) intersects [base, end)
> +       the intersection is [log, high) */
> +    if (low >= high)
> +        return 0;
> +
> +    return memcmp(orig + low, new + low, high - low);

If orig is kept around in PCIDevice, it can be kept always in sync with
config.  And this way, we can just do memcmp without need for complex range
checks.

> +}
> +
> +static inline int pci_config_changed_with_size(const uint8_t *orig,
> +                                               const uint8_t *new,
> +                                               uint32_t addr, uint32_t len,
> +                                               uint32_t base, uint32_t size)
> +{
> +    uint32_t low = MAX(addr, base);
> +    uint32_t high = MIN(addr + len, base + size);
> +
> +    /* check if [addr, addr + len) intersects [base, base + size)
> +       the intersection is [log, high) */
> +    if (low >= high)
> +        return 0;
> +
> +    return memcmp(orig + low, new + low, high - low);
> +}
> +
>  /* lsi53c895a.c */
>  #define LSI_MAX_DEVS 7
>  
> -- 
> 1.6.0.2
> 
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]