qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH 17/20] pci: remove magic number, 256 in pci.c


From: Michael S. Tsirkin
Subject: [Qemu-devel] Re: [PATCH 17/20] pci: remove magic number, 256 in pci.c
Date: Thu, 12 Nov 2009 12:34:40 +0200
User-agent: Mutt/1.5.19 (2009-01-05)

On Thu, Nov 12, 2009 at 02:58:45PM +0900, Isaku Yamahata wrote:
> This patch replaces magic number, 256, with ARRAY_SIZE().
> 
> Signed-off-by: Isaku Yamahata <address@hidden>

Acked-by: Michael S. Tsirkin <address@hidden>

> ---
>  hw/pci.c |    5 +++--
>  1 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/hw/pci.c b/hw/pci.c
> index 2eff7fe..dce445a 100644
> --- a/hw/pci.c
> +++ b/hw/pci.c
> @@ -487,7 +487,8 @@ static PCIDevice *do_pci_register_device(PCIDevice 
> *pci_dev, PCIBus *bus,
>                                           uint8_t header_type)
>  {
>      if (devfn < 0) {
> -        for(devfn = bus->devfn_min ; devfn < 256; devfn += 8) {
> +        for(devfn = bus->devfn_min ; devfn < ARRAY_SIZE(bus->devices);
> +            devfn += 8) {
>              if (!bus->devices[devfn])
>                  goto found;
>          }
> @@ -1025,7 +1026,7 @@ static void pci_for_each_device_under_bus(PCIBus *bus,
>      PCIDevice *d;
>      int devfn;
>  
> -    for(devfn = 0; devfn < 256; devfn++) {
> +    for(devfn = 0; devfn < ARRAY_SIZE(bus->devices); devfn++) {
>          d = bus->devices[devfn];
>          if (d)
>              fn(bus, d);
> -- 
> 1.6.0.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]