qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 05/20] monitor: Rename monitor_handle_command()


From: Luiz Capitulino
Subject: [Qemu-devel] [PATCH 05/20] monitor: Rename monitor_handle_command()
Date: Thu, 26 Nov 2009 22:58:55 -0200

As this series will add a new kind of Monitor command, it's better
to rename monitor_handle_command() to what it really is:
handle_user_command().

This will avoid confusion.

Signed-off-by: Luiz Capitulino <address@hidden>
---
 monitor.c |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/monitor.c b/monitor.c
index 6c2c1f1..4c402e4 100644
--- a/monitor.c
+++ b/monitor.c
@@ -3292,7 +3292,7 @@ static void monitor_call_handler(Monitor *mon, const 
mon_cmd_t *cmd,
     qobject_decref(data);
 }
 
-static void monitor_handle_command(Monitor *mon, const char *cmdline)
+static void handle_user_command(Monitor *mon, const char *cmdline)
 {
     QDict *qdict;
     const mon_cmd_t *cmd;
@@ -3556,7 +3556,7 @@ static void monitor_read(void *opaque, const uint8_t 
*buf, int size)
         if (size == 0 || buf[size - 1] != 0)
             monitor_printf(cur_mon, "corrupted command\n");
         else
-            monitor_handle_command(cur_mon, (char *)buf);
+            handle_user_command(cur_mon, (char *)buf);
     }
 
     cur_mon = old_mon;
@@ -3565,7 +3565,7 @@ static void monitor_read(void *opaque, const uint8_t 
*buf, int size)
 static void monitor_command_cb(Monitor *mon, const char *cmdline, void *opaque)
 {
     monitor_suspend(mon);
-    monitor_handle_command(mon, cmdline);
+    handle_user_command(mon, cmdline);
     monitor_resume(mon);
 }
 
-- 
1.6.6.rc0.50.gaf06e





reply via email to

[Prev in Thread] Current Thread [Next in Thread]