qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH V9 00/20] split out piix specific part from pc emula


From: Isaku Yamahata
Subject: [Qemu-devel] [PATCH V9 00/20] split out piix specific part from pc emulator
Date: Tue, 8 Dec 2009 17:33:19 +0900

This time, I fixed up the patch series.
  - fixed up copyright notice.
  - make rtc_xxx functions accept/return ISADevice.
  - move up ioapic initalization patch.
Although Gerd suggested to use DeviceState, I used ISADevice.
Gerd, do you want me to use DeviceState instead of ISADevice?

patch series description:
This is the preparation patch for q35 chipset and PCIE support.

This patch series is for spliting out piix specific part from pc emulator
to make it easier to implement other pc chipset emulator.
Although my motivation is for 128+ PCI and another chipset support,
I think this patch series itself is good for readability and maintenance.

thanks,

Changes from V8:
- make rtc_xxx functions accept/return ISADevice.
- move up ioapic initalization patch.
- fixed up copyright notice.

Changes from V7:
- rebased to fe0d61231eb6be6a83c54f4a2795f924ee963f8f

Changes from v6:
- rebased to 731c54f86988d3f28268f184fabfe9b2a32fb5d3

Changes from v5:
- rebased 0.11.0-rc0
- changed qemu_system_powerdown_register() to call
  qemu_system_shutdown_request() if qemu_system_shutdown() is called before
  registering.

Changes from v4:
- fix version number.
- rebased anthony's staging tree whose latest change set is
  62969268f876c547ee64da6d60e0f363e0f1df75

Changes from v3:
- move qemu_system_powerdown() in vl.c and more generic
  following the comment by Marcelo Tosatti <address@hidden>
  acpi.c: make qemu_system_powerdown() piix independent.
- define cmos_set_s3_resume_init() and cmos_set_s3_resume() in pc.c
  even if TARGET_I386 isn't defined following th ecommit by
  Paolo Bonzini <address@hidden>
  pc.c: remove a global variable, RTCState *rtc_state.
- minor compilation fixes

Changes from v2:
- clean up pc_pci_device_init() not to use unnecessary braces.

Changes from v1:
- make patches full bisectable
- typo s/allocte/allocate/
- some minor fixes
- dropped a merged patch

Isaku Yamahata (20):
  acpi: split out pc smbus routines from acpi.c into pc_smbus.c
  acpi: split out apm register emulation from acpi.c
  acpi: add acpi constants from linux header files and use them.
  acpi: split acpi.c into the common part and the piix4 part.
  acpi_piix4: remove unused variable in get_pmsts().
  pc: initialize ioapic before use.
  pc, i440fx: Make smm enable/disable function i440fx independent.
  pc: make an unnecessary global variable, pit, local.
  pc: remove a global variable, floppy_controller.
  pc: Remove reference to a global variable, RTCState *rtc_state.
  pc: introduce a function to allocate cpu irq.
  pc: make pc_init1() not refer ferr_irq directly.
  pc: split out cpu initialization from pc_init1() into pc_cpus_init().
  pc: split out memory allocation from pc_init1() into pc_memory_init()
  pc: split out vga initialization from pc_init1() into pc_vga_init().
  pc: split out basic device init from pc_init1() into
    pc_basic_device_init()
  pc: split out pci device init from pc_init1() into
    pc_pci_device_init()
  pc: split out piix specific part from pc.c into pc_piix.c
  pc: move rtc declarations from pc.h into a dedicated header file.
  rtc: make rtc_xxx accept/return ISADevice instead of RTCState.

 Makefile.target  |    2 +
 hw/acpi.c        |  738 +-----------------------------------------------------
 hw/acpi.h        |   78 ++++++
 hw/acpi_piix4.c  |  578 ++++++++++++++++++++++++++++++++++++++++++
 hw/mc146818rtc.c |   26 ++-
 hw/mc146818rtc.h |   10 +
 hw/mips_jazz.c   |    1 +
 hw/mips_malta.c  |    3 +-
 hw/mips_r4k.c    |    3 +-
 hw/pc.c          |  343 ++++++++------------------
 hw/pc.h          |   52 ++++-
 hw/pc_apm.c      |   85 +++++++
 hw/pc_apm.h      |   22 ++
 hw/pc_piix.c     |  244 ++++++++++++++++++
 hw/pc_smbus.c    |  178 +++++++++++++
 hw/pc_smbus.h    |   21 ++
 hw/piix_pci.c    |    5 +-
 hw/ppc_prep.c    |    1 +
 18 files changed, 1392 insertions(+), 998 deletions(-)
 create mode 100644 hw/acpi.h
 create mode 100644 hw/acpi_piix4.c
 create mode 100644 hw/mc146818rtc.h
 create mode 100644 hw/pc_apm.c
 create mode 100644 hw/pc_apm.h
 create mode 100644 hw/pc_piix.c
 create mode 100644 hw/pc_smbus.c
 create mode 100644 hw/pc_smbus.h





reply via email to

[Prev in Thread] Current Thread [Next in Thread]