qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PULL] qemu/master: pci cleanups and a bugfix


From: Michael S. Tsirkin
Subject: [Qemu-devel] [PULL] qemu/master: pci cleanups and a bugfix
Date: Wed, 23 Dec 2009 17:06:04 +0200
User-agent: Mutt/1.5.19 (2009-01-05)

This includes pci cleanups, which I think are very safe.  They have been
out for quite a while.  It also puts back interrupt disable bit support,
which was mistakenly reverted on master.

The following changes since commit 59d1c1c2d774cccb0a88ff73501f97bea190c154:
  Scott Tsai (1):
        USB: Improve usbdevice error messages

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/mst/qemu.git for_anthony

Isaku Yamahata (10):
      pci: remove PCIBus::config_reg.
      pci: s/PCI_SUBVENDOR_ID/PCI_SUBSYSTEM_VENDOR_ID/g
      pci: import Linux pci_regs.h
      pci: use pci_regs.h
      gt64xxx: remove gt64120_{read, write}_config().
      acpi: use range helper function.
      msix: use range helper function.
      piix_pci: define symbolic value for PAM0, PAM6 and SMRAM.
      piix_pci: use range helper function
      piix_pci: add link to i440fx data sheet.

Michael S. Tsirkin (19):
      Revert "Revert "pci: interrupt disable bit support""
      e1000: switch to symbolic names for pci registers
      ne2000: switch to symbolic names for pci registers
      rtl: switch to symbolic names for pci registers
      pcnet: switch to symbolic names for pci registers
      pci: add more status bits
      eepro100: symbolic names for pci registers
      piix: symbolic constants
      cmd646: symbolic names for pci registers
      vmware_vga: symbolic names for pci registers
      lsi: symbolic names for pci registers
      pci: add another devsel macro
      es1370: symbolic names for pci registers
      wdt_i6300esb: symbolic names for pci registers
      ac97: symbolic names for pci registers
      usb-uhci: symbolic names for pci registers
      usb-ohci: symbolic names for pci registers
      pci: remove unused macro
      list MST as pci layer maintainer

 MAINTAINERS       |    2 +-
 hw/ac97.c         |   57 +++--
 hw/acpi.c         |    2 +-
 hw/e1000.c        |   11 +-
 hw/eepro100.c     |   49 +++--
 hw/es1370.c       |   29 ++--
 hw/gt64xxx.c      |   13 +-
 hw/ide/cmd646.c   |    7 +-
 hw/ide/piix.c     |   13 +-
 hw/lsi53c895a.c   |   10 +-
 hw/msix.c         |    2 +-
 hw/ne2000.c       |    3 +-
 hw/pci.c          |   32 +++-
 hw/pci.h          |   73 +------
 hw/pci_regs.h     |  665 +++++++++++++++++++++++++++++++++++++++++++++++++++++
 hw/pcnet.c        |   26 ++-
 hw/piix_pci.c     |   22 ++-
 hw/rtl8139.c      |   16 +-
 hw/usb-ohci.c     |    6 +-
 hw/usb-uhci.c     |    7 +-
 hw/vmware_vga.c   |   20 +-
 hw/wdt_i6300esb.c |    2 +-
 22 files changed, 869 insertions(+), 198 deletions(-)
 create mode 100644 hw/pci_regs.h




reply via email to

[Prev in Thread] Current Thread [Next in Thread]