qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH 09/15] usb-linux.c: fix warning with _FORTIFY_SO


From: Michael S. Tsirkin
Subject: [Qemu-devel] Re: [PATCH 09/15] usb-linux.c: fix warning with _FORTIFY_SOURCE
Date: Tue, 5 Jan 2010 18:36:47 +0200
User-agent: Mutt/1.5.19 (2009-01-05)

On Tue, Jan 05, 2010 at 06:07:35PM +0200, Kirill A. Shutemov wrote:
> On Tue, Jan 5, 2010 at 4:42 PM, Juan Quintela <address@hidden> wrote:
> > "Kirill A. Shutemov" <address@hidden> wrote:
> >>   CC    usb-linux.o
> >> cc1: warnings being treated as errors
> >> usb-linux.c: In function 'usb_host_read_file':
> >> usb-linux.c:1204: error: ignoring return value of 'fgets', declared with 
> >> attribute warn_unused_result
> >> make: *** [usb-linux.o] Error 1
> >>
> >> Signed-off-by: Kirill A. Shutemov <address@hidden>
> >> ---
> >>  usb-linux.c |    8 ++++++--
> >>  1 files changed, 6 insertions(+), 2 deletions(-)
> >>
> >> diff --git a/usb-linux.c b/usb-linux.c
> >> index 88728e9..8673474 100644
> >> --- a/usb-linux.c
> >> +++ b/usb-linux.c
> >> @@ -1201,9 +1201,13 @@ static int usb_host_read_file(char *line, size_t 
> >> line_size, const char *device_f
> >>               device_file);
> >>      f = fopen(filename, "r");
> >>      if (f) {
> >> -        fgets(line, line_size, f);
> >> +        if (fgets(line, line_size, f)) {
> >> +            ret = 1;
> >> +        } else {
> >> +            ret = 0;
> >> +        }
> >> +
> > This if is equivalent to:
> >
> > ret = !!fgets(line, line_size, f);
> >
> > No need for the if at all :)
> 
> It's not very readable.
> Probably better to use something like:
> 
> ret = (fgets(line, line_size, f) != NULL);
> 

Might be matter of taste. E.g. I think !! is more readable than != NULL.
And () around != are not needed.  It's better to make code brief IMO,
a lof of boilerplate hides bugs.

Nothing to get hung about though.

-- 
MST




reply via email to

[Prev in Thread] Current Thread [Next in Thread]