qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: Re: [RFC] [PATCH] add ahci support into qemu


From: Sebastian Herbszt
Subject: [Qemu-devel] Re: Re: [RFC] [PATCH] add ahci support into qemu
Date: Thu, 6 May 2010 21:10:18 +0200

Stuart Brady wrote:
On Tue, May 04, 2010 at 10:51:37PM +0200, Sebastian Herbszt wrote:
>diff --git a/hw/pci_ids.h b/hw/pci_ids.h
>index fe7a121..4d4de93 100644
>--- a/hw/pci_ids.h
>+++ b/hw/pci_ids.h
>@@ -97,3 +97,4 @@
>#define PCI_DEVICE_ID_INTEL_82371AB      0x7111
>#define PCI_DEVICE_ID_INTEL_82371AB_2    0x7112
>#define PCI_DEVICE_ID_INTEL_82371AB_3    0x7113
>+#define PCI_DEVICE_ID_INTEL_ICH6R_AHCI    0x2652

The list is sorted by vendor and device id. This entry should go
after "PCI_DEVICE_ID_INTEL_ESB_9". The naming scheme seems
to be VENDOR_DEVICE_FUNCTION, so i suggest something like
PCI_DEVICE_ID_INTEL_ICH6R_2 or PCI_DEVICE_ID_INTEL_82801FR_2.

Linux seems to have called this PCI_DEVICE_ID_INTEL_ICH6_4 at one point.

So this should be function 4, no?

Well, i am not sure if the last part is the function number. pci_ids.h from the 
linux
kernel got this:

#define PCI_DEVICE_ID_INTEL_ICH6_0      0x2640
#define PCI_DEVICE_ID_INTEL_ICH6_1      0x2641
#define PCI_DEVICE_ID_INTEL_ICH6_2      0x2642
#define PCI_DEVICE_ID_INTEL_ICH6_16     0x266a
#define PCI_DEVICE_ID_INTEL_ICH6_17     0x266d
#define PCI_DEVICE_ID_INTEL_ICH6_18     0x266e
#define PCI_DEVICE_ID_INTEL_ICH6_19     0x266f

According to the Intel spec the SATA controller is D31:F2. So we got device 31
and function 2. The IDE controller is D31:F1, but above it's ICH6_19.

Sebastian

Cheers,
--
Stuart Brady







reply via email to

[Prev in Thread] Current Thread [Next in Thread]