qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [Tracing][RFC] QMP interface to toggle state of a trace


From: Prerna Saxena
Subject: [Qemu-devel] Re: [Tracing][RFC] QMP interface to toggle state of a trace-event
Date: Thu, 21 Oct 2010 12:24:44 +0530
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.9) Gecko/20100921 Fedora/3.1.4-1.fc13 Thunderbird/3.1.4


Thanks for the review!

On 10/21/2010 12:53 AM, Luiz Capitulino wrote:
On Wed, 20 Oct 2010 15:28:49 +0530
Prerna Saxena<address@hidden>  wrote:

QMP command trace-event to toggle state of a trace-event.
  Illustration :
  ->  { "execute": "trace-event", "arguments": { "name": "qemu_malloc", 
"option": true} }
  <- { "return": {} }

Posting this as an RFC for now. I'll post the final version as a part of
  the cumulative QMP patchset for tracing ( including patches for query-*
commands posted earlier :
http://lists.gnu.org/archive/html/qemu-devel/2010-10/msg01232.html )

Signed-off-by: Prerna Saxena<address@hidden>
---
  hmp-commands.hx |    2 +-
  monitor.c       |   43 +++++++++++++++++++++++++++++++++++++------
  qmp-commands.hx |   32 ++++++++++++++++++++++++++++++++
  3 files changed, 70 insertions(+), 7 deletions(-)
diff --git a/qmp-commands.hx b/qmp-commands.hx
index bc79b55..7613d73 100644
--- a/qmp-commands.hx
+++ b/qmp-commands.hx
@@ -761,6 +761,38 @@ Example:

  Note: This command must be issued before issuing any other command.

+EQMP
+
+    {
+        .name       = "trace-event",
+        .args_type  = "name:s,option:b",
+        .params     = "name on|off",
+        .help       = "changes state of a specific trace event",
+        .user_print = monitor_user_noop,
+        .mhandler.cmd_new = do_change_trace_event_state_qmp,
+    },
+
+SQMP
+trace-event
+-----------
+
+Change state of a trace-event.
+
+Arguments:
+
+- "name": name of trace-event (json-string)
+- "option": new state for the trace-event (json-bool)

This should be called 'enabled'.


I agree, 'enabled' is less ambiguous. Will change in the next patchset.


I think you should submit a new series containing only the proposed
interfaces documentation (one patch per interface) and the intro email
should describe the use cases the proposed interfaces are supposed to
address.

I'll send out the new documentation patchset series shortly.

+
+Example:
+
+->  { "execute": "trace-event", "arguments": { "name": "ABC", "option":false } 
}
+<- { "return": {} }
+
+Notes:
+
+(1) The 'query-trace-events' command should be used to check the new state
+    of the trace-event.
+
  3. Query Commands
  =================




--
Prerna Saxena

Linux Technology Centre,
IBM Systems and Technology Lab,
Bangalore, India



reply via email to

[Prev in Thread] Current Thread [Next in Thread]