qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/3] nmi: convert cpu_index to cpu-index


From: Markus Armbruster
Subject: Re: [Qemu-devel] [PATCH 1/3] nmi: convert cpu_index to cpu-index
Date: Mon, 20 Dec 2010 18:00:34 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

Lai Jiangshan <address@hidden> writes:

> "cpu-index" is better name.
>
> Signed-off-by:  Lai Jiangshan <address@hidden>
> ---
> diff --git a/hmp-commands.hx b/hmp-commands.hx
> index 4befbe2..8de7aa3 100644
> --- a/hmp-commands.hx
> +++ b/hmp-commands.hx
> @@ -721,7 +721,7 @@ ETEXI
>  #if defined(TARGET_I386)
>      {
>          .name       = "nmi",
> -        .args_type  = "cpu_index:i",
> +        .args_type  = "cpu-index:i",
>          .params     = "cpu",
>          .help       = "inject an NMI on the given CPU",
>          .mhandler.cmd = do_inject_nmi,
> diff --git a/monitor.c b/monitor.c
> index 5d74fe3..c16b39d 100644
> --- a/monitor.c
> +++ b/monitor.c
> @@ -2410,7 +2410,7 @@ static void do_wav_capture(Monitor *mon, const QDict 
> *qdict)
>  static void do_inject_nmi(Monitor *mon, const QDict *qdict)
>  {
>      CPUState *env;
> -    int cpu_index = qdict_get_int(qdict, "cpu_index");
> +    int cpu_index = qdict_get_int(qdict, "cpu-index");
>  
>      for (env = first_cpu; env != NULL; env = env->next_cpu)
>          if (env->cpu_index == cpu_index) {

Fine with me, but it would be nice if we could make up our mind once and
for all whether to use dash or underscore in monitor commands and
arguments.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]