qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH V6 1/4] nmi: convert cpu_index to cpu-index


From: Luiz Capitulino
Subject: [Qemu-devel] Re: [PATCH V6 1/4] nmi: convert cpu_index to cpu-index
Date: Tue, 1 Feb 2011 11:29:15 -0200

On Thu, 27 Jan 2011 16:20:27 +0800
Lai Jiangshan <address@hidden> wrote:

> "cpu-index" which uses hyphen is better name.
> 
> Signed-off-by:  Lai Jiangshan <address@hidden>

It looks ok from a quick pass, but I can't apply it on current master, what
commit HEAD did you?

Btw, please, do include the patch 0/0 with a general description about the
series and a small changelog between changes.

> ---
> diff --git a/hmp-commands.hx b/hmp-commands.hx
> index 5d4cb9e..e43ac7c 100644
> --- a/hmp-commands.hx
> +++ b/hmp-commands.hx
> @@ -721,7 +721,7 @@ ETEXI
>  #if defined(TARGET_I386)
>      {
>          .name       = "nmi",
> -        .args_type  = "cpu_index:i",
> +        .args_type  = "cpu-index:i",
>          .params     = "cpu",
>          .help       = "inject an NMI on the given CPU",
>          .mhandler.cmd = do_inject_nmi,
> diff --git a/monitor.c b/monitor.c
> index 27883f8..a916771 100644
> --- a/monitor.c
> +++ b/monitor.c
> @@ -2545,7 +2545,7 @@ static void do_wav_capture(Monitor *mon, const QDict 
> *qdict)
>  static void do_inject_nmi(Monitor *mon, const QDict *qdict)
>  {
>      CPUState *env;
> -    int cpu_index = qdict_get_int(qdict, "cpu_index");
> +    int cpu_index = qdict_get_int(qdict, "cpu-index");
>  
>      for (env = first_cpu; env != NULL; env = env->next_cpu)
>          if (env->cpu_index == cpu_index) {
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]