qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Re: [PATCH 18/21] move blocking of signals to qemu_signalfd


From: Jan Kiszka
Subject: [Qemu-devel] Re: [PATCH 18/21] move blocking of signals to qemu_signalfd_init
Date: Mon, 21 Feb 2011 11:26:42 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.1.12) Gecko/20080226 SUSE/2.0.0.12-1.1 Thunderbird/2.0.0.12 Mnenhy/0.7.5.666

On 2011-02-21 11:20, Paolo Bonzini wrote:
> On 02/21/2011 11:12 AM, Jan Kiszka wrote:
>> On 2011-02-21 09:43, Paolo Bonzini wrote:
>>> This makes it easier to add a Win32 stub.  The patch does that, too.
>>>
>>> Signed-off-by: Paolo Bonzini<address@hidden>
>>> ---
>>>   cpus.c |   87 
>>> ++++++++++++++++++++++++++-------------------------------------
>>>   1 files changed, 36 insertions(+), 51 deletions(-)
>>>
>>> diff --git a/cpus.c b/cpus.c
>>> index 1b6893d..5bb95d8 100644
>>> --- a/cpus.c
>>> +++ b/cpus.c
>>> @@ -346,11 +346,37 @@ static void sigfd_handler(void *opaque)
>>>       }
>>>   }
>>>
>>> -static int qemu_signalfd_init(sigset_t mask)
>>> +static int qemu_signalfd_init(void)
>>>   {
>>>       int sigfd;
>>> +    sigset_t set;
>>>
>>> -    sigfd = qemu_signalfd(&mask);
>>> +#ifdef CONFIG_IOTHREAD
>>> +    /* SIGUSR2 used by posix-aio-compat.c */
>>> +    sigemptyset(&set);
>>> +    sigaddset(&set, SIGUSR2);
>>> +    pthread_sigmask(SIG_UNBLOCK,&set, NULL);
>>
>> These lines are actually not related to signalfd setup. So you may want
>> to rename this function or move everything that does not block signals
>> and then pass the very same set to qemu_signalfd elsewhere.
> 
> Ok, I'll just rename qemu_signalfd_init to qemu_init_iothread_signals.
> 
>> For consistency reasons, you should also refactor the !IOTHREAD case.
> 
> I think I did?

Yeah, I must have missed that qemu_signalfd_init was already refactored
by whoever :) to be independent of CONFIG_IOTHREAD.

Jan

-- 
Siemens AG, Corporate Technology, CT T DE IT 1
Corporate Competence Center Embedded Linux



reply via email to

[Prev in Thread] Current Thread [Next in Thread]