qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 01/12] char: rename qemu_chr_write() to qemu_chr


From: Anthony Liguori
Subject: Re: [Qemu-devel] [PATCH 01/12] char: rename qemu_chr_write() to qemu_chr_fe_write()
Date: Thu, 04 Aug 2011 11:22:57 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110516 Lightning/1.0b2 Thunderbird/3.1.10

On 08/04/2011 11:17 AM, Avi Kivity wrote:
On 08/04/2011 07:14 PM, Avi Kivity wrote:

Yes, I'm just talking about the function names, not about the
implementation.

qemu_chr_fe_write(chr,...) -> qemu_chr_write(chr, ...)
qemu_chr_be_write(chr, ...) -> qemu_chr_write(&chr->backend, ...)


And, if you want an internal pipe:

QemuPipeEndpoint pipe1, pipe2;

qemu_chr_pipe_init(&pipe0, &pipe1);

so clients don't have to choose between frontend and backend. Finally
you can connect COM1: to COM2: with a qemu-provided null modem cable!

Yes, that's exactly the goal :-)

The only problem left to be resolved is how to handle ioctl(). qemu_chr_ioctl() forces asymmetry today.

I think if we merge ioctl into qemu_chr_event() by adding a return and data payload, it'll make the semantics be synchronous messaging and it'll be easy to make ioctl work.

Regards,

Anthony Liguori






reply via email to

[Prev in Thread] Current Thread [Next in Thread]