qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 09/45] ide/atapi: Clean up misleading name in


From: Kevin Wolf
Subject: Re: [Qemu-devel] [PATCH v2 09/45] ide/atapi: Clean up misleading name in cmd_start_stop_unit()
Date: Fri, 02 Sep 2011 12:20:28 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20110816 Thunderbird/6.0

Am 03.08.2011 15:07, schrieb Markus Armbruster:
> "eject" is misleading; it means "eject" when start is clear, but
> "load" when start is set.  Rename to loej, because that's how MMC-5
> calls it, in section 6.40.
> 
> Signed-off-by: Markus Armbruster <address@hidden>
> ---
>  hw/ide/atapi.c |    8 ++++----
>  1 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
> index fe2fb0b..17fbef8 100644
> --- a/hw/ide/atapi.c
> +++ b/hw/ide/atapi.c
> @@ -892,11 +892,11 @@ static void cmd_seek(IDEState *s, uint8_t* buf)
>  
>  static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
>  {
> -    int start, eject, sense, err = 0;
> -    start = buf[4] & 1;
> -    eject = (buf[4] >> 1) & 1;
> +    int sense, err = 0;
> +    bool start = buf[4] & 1;
> +    bool loej = buf[4] & 2;
>  
> -    if (eject) {
> +    if (loej) {
>          err = bdrv_eject(s->bs, !start);
>      }
>  

"eject" has the advantage that I immediately know that it's something to
do with the tray. "loej" on the other hand is a sequence of four random
characters. Maybe add a comment?

Kevin



reply via email to

[Prev in Thread] Current Thread [Next in Thread]