qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3 03/15] add qemu_send_full and qemu_recv_full


From: Kevin Wolf
Subject: Re: [Qemu-devel] [PATCH v3 03/15] add qemu_send_full and qemu_recv_full
Date: Fri, 14 Oct 2011 11:52:18 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20110927 Thunderbird/7.0

Am 05.10.2011 09:17, schrieb Paolo Bonzini:
> Signed-off-by: Paolo Bonzini <address@hidden>
> ---
>  osdep.c       |   67 
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>  qemu-common.h |    4 +++
>  2 files changed, 71 insertions(+), 0 deletions(-)
> 
> diff --git a/osdep.c b/osdep.c
> index 56e6963..718a25d 100644
> --- a/osdep.c
> +++ b/osdep.c
> @@ -166,3 +166,70 @@ int qemu_accept(int s, struct sockaddr *addr, socklen_t 
> *addrlen)
>  
>      return ret;
>  }
> +
> +/*
> + * A variant of send(2) which handles partial write.
> + *
> + * Return the number of bytes transferred, which is only
> + * smaller than `count' if there is an error.
> + *
> + * This function won't work with non-blocking fd's.
> + * Any of the possibilities with non-bloking fd's is bad:
> + *   - return a short write (then name is wrong)
> + *   - busy wait adding (errno == EAGAIN) to the loop
> + */
> +ssize_t qemu_send_full(int fd, const void *buf, size_t count, int flags)
> +{
> +    ssize_t ret = 0;
> +    ssize_t total = 0;
> +
> +    while (count) {
> +        ret = send(fd, buf, count, flags);
> +        if (ret < 0) {
> +            if (errno == EINTR) {
> +                continue;
> +            }
> +            break;
> +        }
> +
> +        count -= ret;
> +        buf += ret;
> +        total += ret;
> +    }
> +
> +    return total;
> +}
> +
> +/*
> + * A variant of recv(2) which handles partial write.
> + *
> + * Return the number of bytes transferred, which is only
> + * smaller than `count' if there is an error.
> + *
> + * This function won't work with non-blocking fd's.
> + * Any of the possibilities with non-bloking fd's is bad:
> + *   - return a short write (then name is wrong)
> + *   - busy wait adding (errno == EAGAIN) to the loop
> + */
> +ssize_t qemu_recv_full(int fd, const void *buf, size_t count, int flags)
> +{
> +    ssize_t ret = 0;
> +    ssize_t total = 0;
> +
> +    while (count) {
> +        ret = recv(fd, buf, count, flags);

osdep.c: In function 'qemu_recv_full':
osdep.c:220: error: passing argument 2 of 'recv' discards qualifiers
from pointer target type
/usr/include/bits/socket2.h:35: note: expected 'void *' but argument is
of type 'const void *'

Kevin



reply via email to

[Prev in Thread] Current Thread [Next in Thread]