qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 4/5] machine: rename phandle_start to phandle-start


From: Luiz Capitulino
Subject: [Qemu-devel] [PATCH 4/5] machine: rename phandle_start to phandle-start
Date: Tue, 10 Jul 2012 16:50:30 -0300

QOM conversion wants option names with dashes (instead of underscores),
this commit does the change for the phandle_start machine option.

The underscore is still supported through an option alias for backwards
compatibility.

Signed-off-by: Luiz Capitulino <address@hidden>
---
 device_tree.c | 2 +-
 qemu-config.c | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/device_tree.c b/device_tree.c
index b366fdd..fe59768 100644
--- a/device_tree.c
+++ b/device_tree.c
@@ -213,7 +213,7 @@ uint32_t qemu_devtree_alloc_phandle(void *fdt)
         machine_opts = qemu_opts_find(qemu_find_opts("machine"), 0);
         if (machine_opts) {
             const char *phandle_start;
-            phandle_start = qemu_opt_get(machine_opts, "phandle_start");
+            phandle_start = qemu_opt_get(machine_opts, "phandle-start");
             if (phandle_start) {
                 phandle = strtoul(phandle_start, NULL, 0);
             }
diff --git a/qemu-config.c b/qemu-config.c
index 909fae9..d888b5b 100644
--- a/qemu-config.c
+++ b/qemu-config.c
@@ -590,7 +590,8 @@ static QemuOptsList qemu_machine_opts = {
             .type = QEMU_OPT_STRING,
             .help = "Dump current dtb to a file and quit",
         }, {
-            .name = "phandle_start",
+            .name = "phandle-start",
+            .alias= "phandle_start",
             .type = QEMU_OPT_STRING,
             .help = "The first phandle ID we may generate dynamically",
         }, {
-- 
1.7.11.1.116.g8228a23




reply via email to

[Prev in Thread] Current Thread [Next in Thread]