qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 2/6] kvm: Rename kvm_irqchip_set_irq to kvm_inje


From: Jan Kiszka
Subject: Re: [Qemu-devel] [PATCH 2/6] kvm: Rename kvm_irqchip_set_irq to kvm_inject_async_irq
Date: Wed, 25 Jul 2012 17:58:48 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.8.1.12) Gecko/20080226 SUSE/2.0.0.12-1.1 Thunderbird/2.0.0.12 Mnenhy/0.7.5.666

On 2012-07-25 17:56, Peter Maydell wrote:
> On 25 July 2012 16:55, Avi Kivity <address@hidden> wrote:
>> On 07/25/2012 06:53 PM, Jan Kiszka wrote:
>>> We don't have a synchronous function anymore, it's part of the pre-run
>>> code of x86 IIRC.
>>
>> Right.  There's a DPRINTF() there that talks about injection, too.  So I
>> think this patch can be dropped.
> 
> The main purpose of the patch is to remove 'irqchip' from the
> function name, because the function isn't restricted to use
> with in-kernel irqchips.

Hmm, what was question again? Ah: Do we have an arch that implements it
without providing a (logical) irqchip? At least at this time (including
ARM)?

Jan

-- 
Siemens AG, Corporate Technology, CT RTC ITP SDP-DE
Corporate Competence Center Embedded Linux





reply via email to

[Prev in Thread] Current Thread [Next in Thread]