qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 0/7] Live block commit


From: Jeff Cody
Subject: [Qemu-devel] [PATCH v2 0/7] Live block commit
Date: Tue, 25 Sep 2012 12:29:32 -0400

This series adds the basic case, of a live commit between two
images below the active layer, e.g.:

[base] <--- [snp-1] <--- [snp-2] <--- [snp-3] <--- [active]

can be collapsed down via commit, into:

[base] <--- [active]

or,

[base] <--- [snp-1] <--- [active],

[base] <--- [snp-3] <--- [active],

etc..

TODO: * 'stage-2' of live commit functionality, to be able to push down the
        active layer. 

These changes are all reflected in my github repo:

    git://github.com/codyprime/qemu-kvm-jtc.git  branch: jtc-live-commit-1.3-v8

Changes from v1 -> v2:
===================================

Patch 1/7: [Eric] - Commit message cleanup
                  - Make comments clearer
                  - fixed whitespace removal

Dropped old Patch 4/8 (new qerror message) - Eric

Patch 2/7:        - Changed error_set() to error_setg()

Patch 5/7: [Eric] - Changed error_set() to error_setg()
                  - Updated comments/docs to be clearer
                  - fixed whitespace removal


Changes from RFC to v1:
===================================

* Feedback incorporated (see below)
* qemu-iotests added
* live snapshots have active->backing_hd reopened read-only.

Patch 1/8: [Kevin] -  Rename bdrv_delete_intermediate() to
                      bdrv_drop_intermediate()
                   -  Change terminology from 'child' to 'overlay'
                   -  Do not allow top == active, and return NULL for error,
                      simplified some logic.

Patch 2/8: [Kevin]       - Preserve errors in commit_populate()
           [Kevin, Eric] - Check that there is enough room in base, and resize
                           with bdrv_truncate() if not.
           [Jeff]        - Switch from 'child' to 'overlay' terminology
                         - Fixed up more error checking
                         - Minor cleanup
           [Kevin]       - Perform the bdrv_reopen() inside commit_start(),
                           instead of in blockdev.c

Patch 3/8: [Paolo]  - Rearranged patch, so the forward declaration is gone
            
Patch 4/8: None
Patch 5/8: None

Patch 6/8: [Eric]   - Updated QMP/qmp-events.txt with the new 'type' field
           [Kevin]  - If base cannot be found, return attempted base name
                    - Moved reopen() logic to commit_start
                    - Fixed comments in JSON command header
           [Jeff]   - If 'top' is not specified, default to active->backing_hd

Patch 7/8: New - simple qemu-iotest for commit.

Patch 8/8: New - after live snapshot, use bdrv_reopen() to reopen
                 active->backing_hd read-only.



Changes from the RFC v1 -> RFC v2:
===================================

* This patch series is not on top of Paolo's blk mirror series yet, to make it
  easier to apply independently if desired.  This means some of what was in the
  previous RFC series is not in this one (BlockdevOnError, for instance), but
  that can be easily added in once Paolo's series are in.

* This patches series is dependent on the reopen() series with transactional
  reopen.

* The target release for this series is 1.3

* Found some mistakes in the reopen calls

* Dropped the BlockdevOnError argument (for now), will add in if rebasing on
  top of Paolo's series.

* Used the new qerror system

Jeff Cody (7):
  block: add support functions for live commit, to find and delete
    images.
  block: add live block commit functionality
  blockdev: rename block_stream_cb to a generic block_job_cb
  block: helper function, to find the base image of a chain
  QAPI: add command for live block commit, 'block-commit'
  qemu-iotests: add initial tests for live block commit
  block: after creating a live snapshot, make old image read-only

 QMP/qmp-events.txt         |   6 +-
 block.c                    | 166 ++++++++++++++++++++++++++++++
 block.h                    |   5 +
 block/Makefile.objs        |   1 +
 block/commit.c             | 246 +++++++++++++++++++++++++++++++++++++++++++++
 block_int.h                |  16 +++
 blockdev.c                 |  75 +++++++++++++-
 qapi-schema.json           |  35 +++++++
 qmp-commands.hx            |   6 ++
 tests/qemu-iotests/040     | 142 ++++++++++++++++++++++++++
 tests/qemu-iotests/040.out |   5 +
 tests/qemu-iotests/group   |   1 +
 trace-events               |   4 +-
 13 files changed, 702 insertions(+), 6 deletions(-)
 create mode 100644 block/commit.c
 create mode 100755 tests/qemu-iotests/040
 create mode 100644 tests/qemu-iotests/040.out

-- 
1.7.11.4




reply via email to

[Prev in Thread] Current Thread [Next in Thread]