qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] hw: Add test device for unittests execution


From: Paolo Bonzini
Subject: Re: [Qemu-devel] [PATCH] hw: Add test device for unittests execution
Date: Thu, 04 Oct 2012 10:04:47 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120911 Thunderbird/15.0.1

Il 04/10/2012 10:02, Peter Maydell ha scritto:
> On 4 October 2012 04:49, Lucas Meneghel Rodrigues <address@hidden> wrote:
>> Add a test device which supports the kvmctl ioports,
>> so one can run the KVM unittest suite [1].
>>
>> Usage:
>>
>> qemu -device testdev
>>
>> 1) Removed port 0xf1, since now kvm-unit-tests use
>>    serial
>>
>> 2) Removed exit code port 0xf4, since that can be
>>    replaced by
>>
>> -device isa-debugexit,iobase=0xf4,access-size=2
>>
>> 3) Removed ram size port 0xd1, since guest memory
>>    size can be retrieved from firmware, there's a
>>    patch for kvm-unit-tests including an API to
>>    retrieve that value.
>>
>> [1] Preliminary versions of this patch were posted
>> to the mailing list about a year ago, I re-read the
>> comments of the thread, and had guidance from
>> Paolo about which ports to remove from the test
>> device.
> 
> General remark: there's no documentation anywhere in
> this patch. I don't necessarily mean user-facing docs,
> but at least a descriptive comment saying what the
> heck this device is and what it does would be helpful.
> 
> 
>>
>> CC: Paolo Bonzini <address@hidden>
>> Signed-off-by: Gerd Hoffmann <address@hidden>
>> Signed-off-by: Avi Kivity <address@hidden>
>> Signed-off-by: Marcelo Tosatti <address@hidden>
>> Signed-off-by: Lucas Meneghel Rodrigues <address@hidden>
>> ---
>>  hw/i386/Makefile.objs |   1 +
>>  hw/testdev.c          | 131 
>> ++++++++++++++++++++++++++++++++++++++++++++++++++
>>  2 files changed, 132 insertions(+)
>>  create mode 100644 hw/testdev.c
>>
>> diff --git a/hw/i386/Makefile.objs b/hw/i386/Makefile.objs
>> index 8c764bb..64d2787 100644
>> --- a/hw/i386/Makefile.objs
>> +++ b/hw/i386/Makefile.objs
>> @@ -11,5 +11,6 @@ obj-$(CONFIG_XEN_PCI_PASSTHROUGH) += xen-host-pci-device.o
>>  obj-$(CONFIG_XEN_PCI_PASSTHROUGH) += xen_pt.o xen_pt_config_init.o 
>> xen_pt_msi.o
>>  obj-y += kvm/
>>  obj-$(CONFIG_SPICE) += qxl.o qxl-logger.o qxl-render.o
>> +obj-y += testdev.o
> 
> ...the device is useful even in non-KVM configs, then?
> 
>>  obj-y := $(addprefix ../,$(obj-y))
>> diff --git a/hw/testdev.c b/hw/testdev.c
>> new file mode 100644
>> index 0000000..44070f2
>> --- /dev/null
>> +++ b/hw/testdev.c
>> @@ -0,0 +1,131 @@
>> +#include <sys/mman.h>
> 
> This file needs a leading comment with the usual copyright/license/
> description of what the file does.
> 
>> +#include "hw.h"
>> +#include "qdev.h"
>> +#include "isa.h"
>> +
>> +struct testdev {
>> +    ISADevice dev;
>> +    MemoryRegion iomem;
>> +    CharDriverState *chr;
>> +};
>> +
>> +#define TYPE_TESTDEV "testdev"
>> +#define TESTDEV(obj) \
>> +     OBJECT_CHECK(struct testdev, (obj), TYPE_TESTDEV)
>> +
>> +static void test_device_irq_line(void *opaque, uint32_t addr, uint32_t data)
>> +{
>> +    struct testdev *dev = opaque;
>> +
>> +    qemu_set_irq(isa_get_irq(&dev->dev, addr - 0x2000), !!data);
>> +}
>> +
>> +static uint32 test_device_ioport_data;
>> +
>> +static void test_device_ioport_write(void *opaque, uint32_t addr, uint32_t 
>> data)
>> +{
>> +    test_device_ioport_data = data;
>> +}
>> +
>> +static uint32_t test_device_ioport_read(void *opaque, uint32_t addr)
>> +{
>> +    return test_device_ioport_data;
>> +}
>> +
>> +static void test_device_flush_page(void *opaque, uint32_t addr, uint32_t 
>> data)
>> +{
>> +    target_phys_addr_t len = 4096;
>> +    void *a = cpu_physical_memory_map(data & ~0xffful, &len, 0);
>> +
>> +    mprotect(a, 4096, PROT_NONE);
>> +    mprotect(a, 4096, PROT_READ|PROT_WRITE);
>> +    cpu_physical_memory_unmap(a, len, 0, 0);
>> +}
>> +
>> +static char *iomem_buf;
>> +
>> +static uint32_t test_iomem_readb(void *opaque, target_phys_addr_t addr)
>> +{
>> +    return iomem_buf[addr];
>> +}
>> +
>> +static uint32_t test_iomem_readw(void *opaque, target_phys_addr_t addr)
>> +{
>> +    return *(uint16_t*)(iomem_buf + addr);
>> +}
>> +
>> +static uint32_t test_iomem_readl(void *opaque, target_phys_addr_t addr)
>> +{
>> +    return *(uint32_t*)(iomem_buf + addr);
>> +}
>> +
>> +static void test_iomem_writeb(void *opaque, target_phys_addr_t addr, 
>> uint32_t val)
>> +{
>> +    iomem_buf[addr] = val;
>> +}
>> +
>> +static void test_iomem_writew(void *opaque, target_phys_addr_t addr, 
>> uint32_t val)
>> +{
>> +    *(uint16_t*)(iomem_buf + addr) = val;
>> +}
>> +
>> +static void test_iomem_writel(void *opaque, target_phys_addr_t addr, 
>> uint32_t val)
>> +{
>> +    *(uint32_t*)(iomem_buf + addr) = val;
>> +}
>> +
>> +static const MemoryRegionOps test_iomem_ops = {
>> +    .old_mmio = {
>> +        .read = { test_iomem_readb, test_iomem_readw, test_iomem_readl, },
>> +        .write = { test_iomem_writeb, test_iomem_writew, test_iomem_writel, 
>> },
>> +    },
>> +    .endianness = DEVICE_LITTLE_ENDIAN,
>> +};
>> +
>> +static int init_test_device(ISADevice *isa)
>> +{
>> +    struct testdev *dev = DO_UPCAST(struct testdev, dev, isa);
>> +
>> +    register_ioport_read(0xe0, 1, 1, test_device_ioport_read, dev);
>> +    register_ioport_write(0xe0, 1, 1, test_device_ioport_write, dev);
>> +    register_ioport_read(0xe0, 1, 2, test_device_ioport_read, dev);
>> +    register_ioport_write(0xe0, 1, 2, test_device_ioport_write, dev);
>> +    register_ioport_read(0xe0, 1, 4, test_device_ioport_read, dev);
>> +    register_ioport_write(0xe0, 1, 4, test_device_ioport_write, dev);
>> +    register_ioport_write(0xe4, 1, 4, test_device_flush_page, dev);
>> +    register_ioport_write(0x2000, 24, 1, test_device_irq_line, NULL);
>> +    iomem_buf = g_malloc0(0x10000);
>> +    memory_region_init_io(&dev->iomem, &test_iomem_ops, dev,
>> +                          "testdev", 0x10000);
>> +    memory_region_add_subregion(isa_address_space(&dev->dev), 0xff000000,
>> +                                                  &dev->iomem);
>> +    return 0;
>> +}
>> +
>> +static Property testdev_isa_properties[] = {
>> +    DEFINE_PROP_CHR("chardev", struct testdev, chr),
>> +    DEFINE_PROP_END_OF_LIST(),
>> +};
>> +
>> +static void testdev_class_init(ObjectClass *klass, void *data)
>> +{
>> +    DeviceClass *dc = DEVICE_CLASS(klass);
>> +    ISADeviceClass *k = ISA_DEVICE_CLASS(klass);
>> +
>> +    k->init = init_test_device;
>> +    dc->props = testdev_isa_properties;
>> +}
>> +
>> +static TypeInfo testdev_info = {
>> +    .name           = "testdev",
> 
> Overly generic name?
> 
>> +    .parent         = TYPE_ISA_DEVICE,
>> +    .instance_size  = sizeof(struct testdev),
>> +    .class_init     = testdev_class_init,
>> +};
> 
> Can this be generalised to not be specifically an ISA
> device? (that's rather an x86-ism).

The IRQ parts are specifically ISA.

> Would the device be
> useful for unit tests of other KVM architectures? Or
> are we providing it purely for a legacy x86 testsuite?

It's not a legacy testsuite, but it's mostly x86-specific, testing
features that are exclusive to the x86 port (such as emulation, power
management, interrupt routing, etc.).

Paolo

>> +
>> +static void testdev_register_types(void)
>> +{
>> +    type_register_static(&testdev_info);
>> +}
>> +
>> +type_init(testdev_register_types)
>> --
>> 1.7.11.4
>>
>>
> 
> thanks
> -- PMM
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]