qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 01/22] Remove TARGET_PHYS_ADDR_BITS define compl


From: Peter Maydell
Subject: Re: [Qemu-devel] [PATCH 01/22] Remove TARGET_PHYS_ADDR_BITS define completely
Date: Mon, 29 Oct 2012 10:38:29 +0000

On 29 October 2012 10:25, Alexander Graf <address@hidden> wrote:
> From: Peter Maydell <address@hidden>
>
> Following commit 4be403c81 TARGET_PHYS_ADDR_BITS is always 64,
> and it's only used in one place (that commit removed all the
> other uses). Remove it completely, to avoid confusion with
> the genuinely useful TARGET_PHYS_ADDR_SPACE_BITS.
>
> Signed-off-by: Peter Maydell <address@hidden>
> Signed-off-by: Alexander Graf <address@hidden>
> ---
>  target-ppc/mmu_helper.c |    2 --
>  1 files changed, 0 insertions(+), 2 deletions(-)
>
> diff --git a/target-ppc/mmu_helper.c b/target-ppc/mmu_helper.c
> index 4a9bb5b..811f47f 100644
> --- a/target-ppc/mmu_helper.c
> +++ b/target-ppc/mmu_helper.c
> @@ -1509,10 +1509,8 @@ static void mmubooke_dump_mmu(FILE *f, 
> fprintf_function cpu_fprintf,
>          mask = ~(entry->size - 1);
>          ea = entry->EPN & mask;
>          pa = entry->RPN & mask;
> -#if (TARGET_PHYS_ADDR_SPACE_BITS >= 36)
>          /* Extend the physical address to 36 bits */
>          pa |= (hwaddr)(entry->RPN & 0xF) << 32;
> -#endif
>          size /= 1024;
>          if (size >= 1024) {
>              snprintf(size_buf, sizeof(size_buf), "%3" PRId64 "M", size / 
> 1024);

The contents and the commit message on this don't match any more,
because when Avi did the target_phys_addr_t to hwaddr patch he
changed this #if (in a different way to how he resolved all the
other #ifs for the force-phys-addrs-to-64-bits patch).

I think the final resulting source tree is the right thing,
so the commit message needs changing. Try:

===begin===
Drop unnecessary check of TARGET_PHYS_ADDR_SPACE_BITS

For all our PPC targets the physical address space is at least
36 bits, so drop an unnecessary preprocessor conditional check
on TARGET_PHYS_ADDR_SPACE_BITS (erroneously introduced as part
of the change from target_phys_addr_t to hwaddr). This brings
this bit of code into line with the way we handle the other
cases which were originally checking TARGET_PHYS_ADDR_BITS in
order to avoid compiler complaints about overflowing a 32 bit type.
===endit===

-- PMM



reply via email to

[Prev in Thread] Current Thread [Next in Thread]