qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PULL 00/36] usb patch queue


From: Anthony Liguori
Subject: Re: [Qemu-devel] [PULL 00/36] usb patch queue
Date: Mon, 29 Oct 2012 14:25:00 -0500
User-agent: Notmuch/0.13.2+93~ged93d79 (http://notmuchmail.org) Emacs/23.3.1 (x86_64-pc-linux-gnu)

Gerd Hoffmann <address@hidden> writes:

>   Hi,
>
> Here comes the usb patch queue.  Nothing big standing out.  Tons of
> cleanups and small bug fixes.  Some performance improvements too.
> Some patches preparing the usb core for the upcoming input pipelining
> bits.
>
> please pull,
>   Gerd
>

Pulled. Thanks.

Regards,

Anthony Liguori

> The following changes since commit a8170e5e97ad17ca169c64ba87ae2f53850dab4c:
>
>   Rename target_phys_addr_t to hwaddr (2012-10-23 08:58:25 -0500)
>
> are available in the git repository at:
>   git://git.kraxel.org/qemu usb.68
>
> Gerd Hoffmann (5):
>       xhci: fix function name in error message
>       xhci: flush endpoint context unconditinally
>       xhci: allow disabling interrupters
>       xhci: make number of interrupters and slots configurable
>       xhci: fix usb name in caps
>
> Hans de Goede (31):
>       uhci: Properly unmap packets on cancel / invalid pid
>       uhci: Move checks to continue queuing to uhci_fill_queue()
>       ehci: Get rid of packet tbytes field
>       ehci: Set int flag on a short input packet
>       ehci: Improve latency of interrupt delivery and async schedule scanning
>       ehci: Speed up the timer of raising int from the async schedule
>       ehci: Detect going in circles when filling the queue
>       ehci: Retry to fill the queue while waiting for td completion
>       xhci: Add a xhci_ep_nuke_one_xfer helper function
>       usb: Rename __usb_packet_complete to usb_packet_complete_one
>       usb: Add USB_RET_ADD_TO_QUEUE packet result code
>       usb: Move clearing of queue on halt to the core
>       usb: Move short-not-ok handling to the core
>       usb: Add an int_req flag to USBPacket
>       usb: Enforce iso endpoints never returing USB_RET_ASYNC
>       uhci: No need to handle async completion of isoc packets
>       uhci: cleanup: Add an unlink call to uhci_async_cancel()
>       uhci: Don't retry on error
>       uhci: Drop unnecessary forward declaration of some static functions
>       uhci: Move emptying of the queue's asyncs' queue to uhci_queue_free
>       uhci: Rename UHCIAsync->td to UHCIAsync->td_addr
>       uhci: Add uhci_read_td() helper function
>       uhci: Make uhci_fill_queue() actually operate on an UHCIQueue
>       uhci: Store ep in UHCIQueue
>       uhci: Immediately free queues on device disconnect
>       uhci: Verify queue has not been changed by guest
>       uhci: Detect guest td re-use
>       uhci: When the guest marks a pending td non-active, cancel the queue
>       uhci: Always mark a queue valid when we encounter it
>       uhci: Retry to fill the queue while waiting for td completion
>       uhci: Use only one queue for ctrl endpoints
>
>  hw/usb.h            |   28 +++-
>  hw/usb/bus.c        |    8 +
>  hw/usb/core.c       |   28 +++-
>  hw/usb/hcd-ehci.c   |  105 ++++++++------
>  hw/usb/hcd-musb.c   |    3 +-
>  hw/usb/hcd-ohci.c   |    9 +-
>  hw/usb/hcd-uhci.c   |  380 
> +++++++++++++++++++++++++--------------------------
>  hw/usb/hcd-xhci.c   |  169 +++++++++++++++--------
>  hw/usb/host-linux.c |    3 +-
>  hw/usb/redirect.c   |   18 ++-
>  trace-events        |    2 +-
>  11 files changed, 425 insertions(+), 328 deletions(-)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]