qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH qom-cpu v2 0/5] target-alpha: CPU subclasses


From: Andreas Färber
Subject: [Qemu-devel] [PATCH qom-cpu v2 0/5] target-alpha: CPU subclasses
Date: Sun, 9 Dec 2012 02:40:11 +0100

Hello Richard,

I've queued the uncontroversial bits of v1 for the next qom-cpu pull (FYI).
This series attempts to introduce AlphaCPU subclasses in a less mechanical way
and in light of efforts to coordinate the naming scheme across targets.

The -cpu ? support was only rebased for now; due to the type name changes
this output has now changed and it does not include the aliases.

@Eduardo:
Note that I've used ObjectClass as return type to avoid unnecessary g_strdup().
Also note the use of a trivial TYPE() macro to enforce the type name scheme in
the knowledge that string literals are being used, avoiding memory leaks.

Regards,
Andreas

v1 -> v2:
* Drop "2*" CPU types in favor of aliases
* Adopt Eduardo's suggested naming scheme <name>-alpha-cpu
* Move cpu_alpha_init() to cpu.c, turning alpha_translate_init() non-static
* Split off alpha_cpu_realize() from cpu_alpha_init()
* Drop illustratory alpha_cpu_reset() RFC for now

Cc: Richard Henderson <address@hidden>
Cc: Eduardo Habkost <address@hidden>

Andreas Färber (5):
  target-alpha: Let cpu_alpha_init() return AlphaCPU
  alpha: Pass AlphaCPU array to Typhoon
  target-alpha: Avoid leaking the alarm timer over reset
  target-alpha: Turn CPU definitions into subclasses
  target-alpha: Add support for -cpu ?

 hw/alpha_dp264.c          |   18 ++--
 hw/alpha_sys.h            |    2 +-
 hw/alpha_typhoon.c        |   30 ++++---
 target-alpha/cpu-qom.h    |    3 +
 target-alpha/cpu.c        |  219 ++++++++++++++++++++++++++++++++++++++++++++-
 target-alpha/cpu.h        |   18 +++-
 target-alpha/sys_helper.c |    6 +-
 target-alpha/translate.c  |   58 +-----------
 8 Dateien geändert, 267 Zeilen hinzugefügt(+), 87 Zeilen entfernt(-)

-- 
1.7.10.4




reply via email to

[Prev in Thread] Current Thread [Next in Thread]