qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH V3 0/7] Virtio-refactoring part1.


From: fred . konrad
Subject: [Qemu-devel] [PATCH V3 0/7] Virtio-refactoring part1.
Date: Tue, 15 Jan 2013 00:07:59 +0100

From: KONRAD Frederic <address@hidden>

This is the part 1/3 of the virtio-refactoring with some fixes.

It introduces virtio-bus, virtio-pci-bus, virtio-s390-bus, and creates
virtio-pci, virtio-device.

You can clone that from here :
git://git.greensocs.com/qemu_virtio.git virtio_v3_part1

Changes patch v2 -> v3:
    * virtio-bus: change prefix: virtio_device_ -> virtio_bus_.
    * virtio-bus: drop get/set nvectors functions.
    * virtio-pci: use qbus_create_inplace instead of qbus_create.
    * virtio-pci: abstracted.
    * virtio-pci: remove the setting of PCI identifier in
      virtio_pci_device_plugged.
    * virtio-s390: same as above.

Changes since patch v1:
    * virtio-pci: Avoid code duplication (in switch/case).
    * virtio-x-bus: Add the VirtioXBusClass.
    * cut the series.

Changes since v9:
    * Refactored all the remaining devices with the same way as virtio-blk.
    * Moved the virtio device's structure in the header.
    * Fixed the init with only one allocation.
    * Fixed the indentation and code style errors.
    * s390 device's are refactored the same way as pci one.
    * Moved max_dev from BusState to BusClass.

Changes v8 -> v9:
    * Modified virtio-bus.c function name. (virtio_device_ prefix.)
    * Removed qdev_create(..) in virtio-blk-x, object_new
      + object_property_add_child used instead.

Changes v7 -> v8:
    * Moved virtio-blk-pci PCI IDs to "Add the virtio-blk device.".
    * virtio : Added virtio_device_init which init children and plug the device.
    * virtio : Added virtio_common_cleanup in the same way as
      virtio_common_init.
    * virtio-blk : Moved virtio_plug_device to virtio-device init.
    * virtio-blk : Inline the virtio_blk_exit function in
      virtio_blk_device_exit and use virtio_common_cleanup.
    * virtio-s390-bus : Added virtio-s390-bus.
    * virtio-s390-device : Added a virtio-s390-bus.
    * virtio-blk-s390 : Switched to the new API.
    * virtio : removed function pointer.
    * virtio : removed VirtinBindings.
    * virtio : cleaned up init and exit function.

Changes v6 -> v7:
    * virtio-bus : Added virtio-bus-reset.
    * virtio-pci : Fixed virtio-pci-exit.
    * virtio-pci : Added virtio-pci-rst.
    * virtio-pci : Added VirtioPCIClass filled with an init function.
    * virtio-blk : Added virtio_blk_set_conf.
    * virtio-blk : QOM casts.
    * virtio-blk-pci : Switched to the new API.

Changes v5 -> v6:
    * Renamed virtio_common_init_ to virtio_init, modify virtio_common_init to
      allocate and call virtio_init. Drop the unused structure size parameters.
    * Renamed init/exit callback in VirtioBusClass.
    * Renamed virtio_blk_init virtio_blk_common_init.
    * Modified virtio_blk_init to call virtio_blk_common_init.

Changes v4 -> v5:
    * use ERROR_CLASS_GENERIC_ERROR in place of creating a new error type for
      the maximum device limitation. ( Peter )
    * Removed bus_in_use function. We assume that the virtio-bus is not in use,
      when plugin in. ( Peter )
    * Added virtio_bus_destroy_device().
    * Implemented the exit function of virtio-pci.
    * Implemented the init callback for virtio-pci ( must be modified, it still
      access vdev directly. ).
    * Implemented the exit callback for virtio-pci.
    * Started virtio-device refactoring.
    * Started virtio-blk refactoring. 

Changes v3 -> v4:
    * Added virtio-bus.o in Makefile.objs ( accidentally dropped from v3 ).
    * *const* TypeInfo in virtio-bus.
    * Introduced virtio-pci-bus.
    * Reintroduced virtio-pci.
    * Introduced virtio-device.
    * Started virtio-blk refactoring.
    * Added an error type in qerror.h for the "bus full" error.

Changes v2 -> v3:
    * Added VirtioBusClass.
    * Renamed VirtioBus -> VirtioBusState.
    * Renamed qbus -> parent_obj.
    * Plug the device only in a non-full bus.

Changes v1 -> v2:
    * All the little fix you suggest ( License, Debug printf, naming convention,
      ...)
    * Added get_virtio_device_id(), and remove the pci_id* from the VirtioBus
      structure.
    * Added virtio_bus_reset().
    * Added cast macros VIRTIO_BUS.
    * Added virtio_bus_plug_device.
    * Replaced the old-style "bus->qbus" by BUS() macro.

KONRAD Frederic (7):
  qdev: add a maximum device allowed field for the bus.
  virtio-bus: introduce virtio-bus
  virtio-device: refactor virtio-device.
  virtio-pci-bus: introduce virtio-pci-bus.
  virtio-pci: refactor virtio-pci device.
  virtio-s390-bus: add virtio-s390-bus.
  virtio-s390-device: create a virtio-s390-bus during init.

 hw/Makefile.objs     |   1 +
 hw/qdev-core.h       |   2 +
 hw/qdev-monitor.c    |  12 ++++
 hw/s390-virtio-bus.c |  31 ++++++++++
 hw/s390-virtio-bus.h |  18 ++++++
 hw/virtio-bus.c      | 164 +++++++++++++++++++++++++++++++++++++++++++++++++++
 hw/virtio-bus.h      |  94 +++++++++++++++++++++++++++++
 hw/virtio-pci.c      | 155 ++++++++++++++++++++++++++++++++++++++++++++++++
 hw/virtio-pci.h      |  38 +++++++++++-
 hw/virtio.c          |  70 ++++++++++++++++++----
 hw/virtio.h          |  30 ++++++++++
 11 files changed, 601 insertions(+), 14 deletions(-)
 create mode 100644 hw/virtio-bus.c
 create mode 100644 hw/virtio-bus.h

-- 
1.7.11.7




reply via email to

[Prev in Thread] Current Thread [Next in Thread]