qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH qom-cpu-next] cpus: Replace open-coded CPU loop


From: Luiz Capitulino
Subject: Re: [Qemu-devel] [PATCH qom-cpu-next] cpus: Replace open-coded CPU loop in qmp_memsave() with qemu_get_cpu()
Date: Mon, 18 Feb 2013 09:57:55 -0300

On Fri, 15 Feb 2013 15:47:41 +0100
Andreas Färber <address@hidden> wrote:

> No functional change, just less usages of first_cpu and next_cpu fields.
> 
> Signed-off-by: Andreas Färber <address@hidden>

Reviewed-by: Luiz Capitulino <address@hidden>

One comment below.

> ---
>  cpus.c |   11 +++--------
>  1 Datei geändert, 3 Zeilen hinzugefügt(+), 8 Zeilen entfernt(-)
> 
> diff --git a/cpus.c b/cpus.c
> index 41779eb..845e915 100644
> --- a/cpus.c
> +++ b/cpus.c
> @@ -1262,18 +1262,13 @@ void qmp_memsave(int64_t addr, int64_t size, const 
> char *filename,
>          cpu_index = 0;
>      }
>  
> -    for (env = first_cpu; env; env = env->next_cpu) {
> -        cpu = ENV_GET_CPU(env);
> -        if (cpu_index == cpu->cpu_index) {
> -            break;
> -        }
> -    }
> -
> -    if (env == NULL) {
> +    cpu = qemu_get_cpu(cpu_index);
> +    if (cpu == NULL) {
>          error_set(errp, QERR_INVALID_PARAMETER_VALUE, "cpu-index",
>                    "a CPU number");
>          return;
>      }
> +    env = cpu->env_ptr;

I wonder if the callees should be taking a CPUState object instead of
CPUArchState.

>  
>      f = fopen(filename, "wb");
>      if (!f) {




reply via email to

[Prev in Thread] Current Thread [Next in Thread]