qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2] gtk: Replace bogus term "VGA" with "Screen"


From: Anthony Liguori
Subject: Re: [Qemu-devel] [PATCH v2] gtk: Replace bogus term "VGA" with "Screen"
Date: Fri, 22 Feb 2013 09:37:56 -0600
User-agent: Notmuch/0.13.2+93~ged93d79 (http://notmuchmail.org) Emacs/23.3.1 (x86_64-pc-linux-gnu)

Jan Kiszka <address@hidden> writes:

> VGA is a misnomer, only some of our targets have it. Use the more
> generic term "Screen" instead.
>
> Signed-off-by: Jan Kiszka <address@hidden>

Peter and I discussed this in IRC.

I think what I'd prefer to do is add a parameter to
graphics_console_init() for the name of the DisplayState.

This will better support having multiple graphics tabs in the future. I
can spin this patch later today unless you can do it sooner.

Regards,

Anthony Liguori

> ---
>
> Note that we have "screendump" as well, so this makes more sense than
> "VGA". Internal renaming across all QEMU can still be done but is
> beyond the scope of this UI fix.
>
>  ui/gtk.c |    5 +++--
>  1 files changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/ui/gtk.c b/ui/gtk.c
> index 29156be..bc4ec67 100644
> --- a/ui/gtk.c
> +++ b/ui/gtk.c
> @@ -1044,7 +1044,7 @@ static void gd_create_menus(GtkDisplayState *s)
>      separator = gtk_separator_menu_item_new();
>      gtk_menu_append(GTK_MENU(s->view_menu), separator);
>  
> -    s->vga_item = gtk_radio_menu_item_new_with_mnemonic(group, "_VGA");
> +    s->vga_item = gtk_radio_menu_item_new_with_mnemonic(group, _("_Screen"));
>      group = gtk_radio_menu_item_get_group(GTK_RADIO_MENU_ITEM(s->vga_item));
>      gtk_menu_item_set_accel_path(GTK_MENU_ITEM(s->vga_item),
>                                   "<QEMU>/View/VGA");
> @@ -1108,7 +1108,8 @@ void gtk_display_init(DisplayState *ds)
>      qemu_add_mouse_mode_change_notifier(&s->mouse_mode_notifier);
>      qemu_add_vm_change_state_handler(gd_change_runstate, s);
>  
> -    gtk_notebook_append_page(GTK_NOTEBOOK(s->notebook), s->drawing_area, 
> gtk_label_new("VGA"));
> +    gtk_notebook_append_page(GTK_NOTEBOOK(s->notebook), s->drawing_area,
> +                             gtk_label_new(_("Screen")));
>  
>      gd_create_menus(s);
>  
> -- 
> 1.7.3.4




reply via email to

[Prev in Thread] Current Thread [Next in Thread]