qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 0/5] configure: TARGET_ARCH cleanups


From: Paolo Bonzini
Subject: [Qemu-devel] [PATCH v2 0/5] configure: TARGET_ARCH cleanups
Date: Tue, 4 Jun 2013 14:45:23 +0200

We have three variables currently in config-target.h:

- TARGET_ARCH is used to create a unique per-arch symbol, used in #ifdefs.
  It is also used as a string through config-target.h, but this is almost
  always wrong.

- TARGET_ARCH2 is the name of the executable (minus the qemu-/qemu-system-
  prefix); it is not available in config-target.h.

- TARGET_TYPE is an enum but is otherwise the same as TARGET_ARCH2

This series changes all uses of TARGET_ARCH to refer to TARGET_ARCH2
instead (which is renamed to TARGET_NAME).  The TARGET_ARCH #define
is dropped, only the per-arch symbol remains.  TARGET_TYPE is then also
removed since it is serialized to the same string if TARGET_NAME is
used directly.

I included Alon's patch because of a nasty semantic conflict between it
and patch "build: do not use TARGET_ARCH".

Alon Levy (1):
  Add a stp file for usage from build directory

Paolo Bonzini (4):
  build: rename TARGET_ARCH2 to TARGET_NAME
  build: do not use TARGET_ARCH
  main: use TARGET_ARCH only for the target-specific #define
  build: drop TARGET_TYPE

 Makefile.target       | 28 +++++++++++++++++++---------
 arch_init.c           |  4 ++--
 bsd-user/main.c       |  6 +++---
 configure             | 42 ++++++++++++++++++++----------------------
 docs/tracing.txt      |  2 +-
 linux-user/main.c     |  6 +++---
 qapi-schema.json      | 18 +-----------------
 scripts/create_config | 15 +++++----------
 scripts/tracetool.py  | 18 +++++++++---------
 9 files changed, 63 insertions(+), 76 deletions(-)

-- 
1.8.1.4




reply via email to

[Prev in Thread] Current Thread [Next in Thread]